summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-2.8.1.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.8.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild b/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
deleted file mode 100644
index 546644688800..000000000000
--- a/dev-haskell/quickcheck/quickcheck-2.8.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-#hackport: flags: +base4,-base3,templatehaskell:template-haskell
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-MY_PN="QuickCheck"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Automatic testing of Haskell programs"
-HOMEPAGE="https://github.com/nick8325/quickcheck"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="2/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="+template-haskell"
-
-RDEPEND="dev-haskell/random:=[profile?]
- >=dev-haskell/tf-random-0.4:=[profile?]
- >=dev-haskell/transformers-0.2:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-base3 \
- --flag=base4 \
- $(cabal_flag template-haskell templatehaskell)
-}