summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/random/random-1.2.1.ebuild')
-rw-r--r--dev-haskell/random/random-1.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-haskell/random/random-1.2.1.ebuild b/dev-haskell/random/random-1.2.1.ebuild
new file mode 100644
index 000000000000..f0b36315ebd3
--- /dev/null
+++ b/dev-haskell/random/random-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite circular depend
+inherit haskell-cabal
+
+DESCRIPTION="Pseudo-random number generation"
+HOMEPAGE="https://hackage.haskell.org/package/random"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+# circular depend: random[test]->mwc-random->math-functions[test]->vector-th-unbox->vector->random
+RESTRICT=test
+
+RDEPEND=">=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/splitmix-0.1:=[profile?] <dev-haskell/splitmix-0.2:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"