summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/rebase')
-rw-r--r--dev-haskell/rebase/Manifest1
-rw-r--r--dev-haskell/rebase/metadata.xml27
-rw-r--r--dev-haskell/rebase/rebase-1.4.1.ebuild45
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-haskell/rebase/Manifest b/dev-haskell/rebase/Manifest
deleted file mode 100644
index 2f24e814cad4..000000000000
--- a/dev-haskell/rebase/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST rebase-1.4.1.tar.gz 19413 BLAKE2B 965f5633496df14611e496150e3fed91324df7189fd1e6c8ec6c2bf7492287b97c716c7da60f61e36740a9e535daf8ee3f7f6349615055a3ec093e167c825605 SHA512 70bb6513e6ea6a1cd3adf077fe454cf4f1a3b220224fc76e3d63050f17c22cc2d218efa8803f269a3605cb0b95e7ea11b3e8b55ec80cd7fb2db4dbf330739a18
diff --git a/dev-haskell/rebase/metadata.xml b/dev-haskell/rebase/metadata.xml
deleted file mode 100644
index b5b31fd8ab3f..000000000000
--- a/dev-haskell/rebase/metadata.xml
+++ /dev/null
@@ -1,27 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- This package is intended for those who are tired of keeping
- long lists of dependencies to the same essential libraries in each package
- as well as the endless imports of the same APIs all over again.
- It also supports the modern tendencies in the language.
-
- To solve those problems this package does the following:
-
- * Reexport the original APIs under the \"Rebase\" namespace.
-
- * Export all the possible non-conflicting symbols from the \"Rebase.Prelude\" module.
-
- * Give priority to the modern practices in the conflicting cases.
-
- The policy behind the package is only to reexport the non-ambiguous
- and non-controversial APIs, which the community has obviously settled on.
- The package is intended to rapidly evolve with the contribution from the community,
- with the missing features being added with pull-requests.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-haskell/rebase/rebase-1.4.1.ebuild b/dev-haskell/rebase/rebase-1.4.1.ebuild
deleted file mode 100644
index 7aa91c52580e..000000000000
--- a/dev-haskell/rebase/rebase-1.4.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.3
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="A more progressive alternative to the 'base' package"
-HOMEPAGE="https://github.com/nikita-volkov/rebase"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/base-prelude-0.1:=[profile?] <dev-haskell/base-prelude-2:=[profile?]
- >=dev-haskell/bifunctors-5:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
- >=dev-haskell/comonad-5:=[profile?] <dev-haskell/comonad-6:=[profile?]
- >=dev-haskell/contravariant-1:=[profile?] <dev-haskell/contravariant-2:=[profile?]
- >=dev-haskell/contravariant-extras-0.3.2:=[profile?] <dev-haskell/contravariant-extras-0.4:=[profile?]
- >=dev-haskell/dlist-0.7:=[profile?] <dev-haskell/dlist-0.9:=[profile?]
- >=dev-haskell/either-5:=[profile?] <dev-haskell/either-6:=[profile?]
- >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-5:=[profile?]
- >=dev-haskell/hashable-1:=[profile?] <dev-haskell/hashable-2:=[profile?]
- >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-3.0:=[profile?]
- >=dev-haskell/profunctors-5:=[profile?] <dev-haskell/profunctors-6:=[profile?]
- >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
- >=dev-haskell/selective-0.3:=[profile?] <dev-haskell/selective-0.4:=[profile?]
- >=dev-haskell/semigroupoids-5.2.2:=[profile?] <dev-haskell/semigroupoids-6:=[profile?]
- >=dev-haskell/semigroups-0.16:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
- >=dev-haskell/stm-2:=[profile?] <dev-haskell/stm-3:=[profile?]
- >=dev-haskell/text-1:=[profile?] <dev-haskell/text-2:=[profile?]
- >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
- >=dev-haskell/uuid-1:=[profile?] <dev-haskell/uuid-2:=[profile?]
- >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.13:=[profile?]
- >=dev-haskell/void-0.7:=[profile?] <dev-haskell/void-0.8:=[profile?]
- >=dev-lang/ghc-8.2.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.0.0.2
-"