summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/regex-posix/regex-posix-0.96.0.0.ebuild')
-rw-r--r--dev-haskell/regex-posix/regex-posix-0.96.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/regex-posix/regex-posix-0.96.0.0.ebuild b/dev-haskell/regex-posix/regex-posix-0.96.0.0.ebuild
new file mode 100644
index 000000000000..bee82d920301
--- /dev/null
+++ b/dev-haskell/regex-posix/regex-posix-0.96.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+#hackport: flags: +newbase,+splitbase,-_regex-posix-clib
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Replaces/Enhances Text.Regex"
+HOMEPAGE="http://hackage.haskell.org/package/regex-posix"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
+ >=dev-haskell/regex-base-0.94:=[profile?] <dev-haskell/regex-base-0.95:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.12
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.3 && < 4.14' 'base >= 4.3'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-_regex-posix-clib \
+ --flag=newbase \
+ --flag=splitbase
+}