summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/rio')
-rw-r--r--dev-haskell/rio/Manifest1
-rw-r--r--dev-haskell/rio/metadata.xml8
-rw-r--r--dev-haskell/rio/rio-0.1.17.0.ebuild38
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/rio/Manifest b/dev-haskell/rio/Manifest
new file mode 100644
index 000000000000..136081a176fc
--- /dev/null
+++ b/dev-haskell/rio/Manifest
@@ -0,0 +1 @@
+DIST rio-0.1.17.0.tar.gz 57839 BLAKE2B f5e2b85b10e20277214a6fc52985ddb51b9c7bbcdcd8e04227f3588a367bba486f42cb1a141973e5f67d6989a524dc3e2d0acc49e3ef3015da0092ab091b1d64 SHA512 a6de6217d3e661063a77bc2af4d8800f5df2967bafb12f30315c59e88aafa238f24a9ed46a6648980cd2e17f14b80e0feff9e1323798e37498a739f7085fddec
diff --git a/dev-haskell/rio/metadata.xml b/dev-haskell/rio/metadata.xml
new file mode 100644
index 000000000000..b7878815d80d
--- /dev/null
+++ b/dev-haskell/rio/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-haskell/rio/rio-0.1.17.0.ebuild b/dev-haskell/rio/rio-0.1.17.0.ebuild
new file mode 100644
index 000000000000..bf055c82a79f
--- /dev/null
+++ b/dev-haskell/rio/rio-0.1.17.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A standard library for Haskell"
+HOMEPAGE="https://github.com/commercialhaskell/rio#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/exceptions:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/microlens:=[profile?]
+ dev-haskell/microlens-mtl:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/typed-process-0.2.5.0:=[profile?]
+ >=dev-haskell/unliftio-0.2.12:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.2.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0.0.2
+ test? ( dev-haskell/hspec
+ dev-haskell/quickcheck )
+"