summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/semirings/semirings-0.6-r2.ebuild')
-rw-r--r--dev-haskell/semirings/semirings-0.6-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/semirings/semirings-0.6-r2.ebuild b/dev-haskell/semirings/semirings-0.6-r2.ebuild
new file mode 100644
index 000000000000..1d556bcd783c
--- /dev/null
+++ b/dev-haskell/semirings/semirings-0.6-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +containers,+unordered-containers
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="two monoids as one, in holy haskimony"
+HOMEPAGE="https://github.com/chessai/semirings"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-haskell/base-compat-batteries:=[profile?]
+ >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.5
+ =dev-haskell/unordered-containers-0.2*:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=containers \
+ --flag=unordered-containers
+}