summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/simple-sendfile/simple-sendfile-0.2.28.ebuild')
-rw-r--r--dev-haskell/simple-sendfile/simple-sendfile-0.2.28.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/simple-sendfile/simple-sendfile-0.2.28.ebuild b/dev-haskell/simple-sendfile/simple-sendfile-0.2.28.ebuild
new file mode 100644
index 000000000000..c69d1870fcf0
--- /dev/null
+++ b/dev-haskell/simple-sendfile/simple-sendfile-0.2.28.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Cross platform library for the sendfile system call"
+HOMEPAGE="http://hackage.haskell.org/package/simple-sendfile"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+allow-bsd"
+
+RDEPEND="dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/conduit
+ dev-haskell/conduit-extra
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/resourcet )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag allow-bsd allow-bsd)
+}