summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/smallcheck')
-rw-r--r--dev-haskell/smallcheck/Manifest1
-rw-r--r--dev-haskell/smallcheck/metadata.xml8
-rw-r--r--dev-haskell/smallcheck/smallcheck-1.2.0.ebuild6
-rw-r--r--dev-haskell/smallcheck/smallcheck-1.2.1.ebuild28
4 files changed, 33 insertions, 10 deletions
diff --git a/dev-haskell/smallcheck/Manifest b/dev-haskell/smallcheck/Manifest
index 651cb217516b..542c73011ebd 100644
--- a/dev-haskell/smallcheck/Manifest
+++ b/dev-haskell/smallcheck/Manifest
@@ -1 +1,2 @@
DIST smallcheck-1.2.0.tar.gz 19047 BLAKE2B 4ecd56b2e0680b4d4e7f80c1c13b9a3a621cae32ec4a8d0605c57fb2bc4882df5f3df05068caf76644286ccd4345fd49f26a73b81f399ca19d1e2200acf0912f SHA512 97c021f3efd6541de99854cb2e8511d4af17225cbcbe17ddfb2efd011d75bd10114b7c8312532bd1c5516e2980b7ad03feb571ec26b91f7258f43460c7bc39a8
+DIST smallcheck-1.2.1.tar.gz 18932 BLAKE2B df248fb94e06eccc1d95ca168a47ecc7ac2853b889b3e778ee36843e5f76caa14dc90182b228610c7a3a24993bb8464ad2ff80f33aa95725b125d54d7b59f6f2 SHA512 42706fb769423bd7f8c2fe7a52d23b8cb4a22bfaabf43b8c29db2923c6413191158801e43d5597258f42ce2430ec81546d172d90246c9d3cf0f9343694eb5eeb
diff --git a/dev-haskell/smallcheck/metadata.xml b/dev-haskell/smallcheck/metadata.xml
index a79f1b7f78af..97abb8fcef64 100644
--- a/dev-haskell/smallcheck/metadata.xml
+++ b/dev-haskell/smallcheck/metadata.xml
@@ -5,13 +5,7 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- SmallCheck is similar to QuickCheck (Claessen and Hughes 2000-) but
- instead of testing for a sample of randomly generated values, SmallCheck
- tests properties for all the finitely many values up to some depth,
- progressively increasing the depth used.
- </longdescription>
<upstream>
- <remote-id type="github">feuerbach/smallcheck</remote-id>
+ <remote-id type="github">Bodigrim/smallcheck</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/smallcheck/smallcheck-1.2.0.ebuild b/dev-haskell/smallcheck/smallcheck-1.2.0.ebuild
index ad622a559f8d..af2f2cb6e783 100644
--- a/dev-haskell/smallcheck/smallcheck-1.2.0.ebuild
+++ b/dev-haskell/smallcheck/smallcheck-1.2.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ebuild generated by hackport 0.6.5.9999
@@ -14,7 +14,7 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE=""
RDEPEND="dev-haskell/logict:=[profile?]
diff --git a/dev-haskell/smallcheck/smallcheck-1.2.1.ebuild b/dev-haskell/smallcheck/smallcheck-1.2.1.ebuild
new file mode 100644
index 000000000000..439d74f19d08
--- /dev/null
+++ b/dev-haskell/smallcheck/smallcheck-1.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A property-based testing library"
+HOMEPAGE="https://github.com/Bodigrim/smallcheck"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-haskell/logict:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/nats:=[profile?]
+ dev-haskell/semigroups:=[profile?]
+ dev-haskell/void:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"