summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/snap-core/snap-core-1.0.4.2.ebuild')
-rw-r--r--dev-haskell/snap-core/snap-core-1.0.4.2.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-haskell/snap-core/snap-core-1.0.4.2.ebuild b/dev-haskell/snap-core/snap-core-1.0.4.2.ebuild
deleted file mode 100644
index 0d7046af4b4e..000000000000
--- a/dev-haskell/snap-core/snap-core-1.0.4.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.5.9999
-#hackport: flags: +network-uri
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Snap: A Haskell Web Framework (core interfaces and types)"
-HOMEPAGE="http://snapframework.com/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug portable"
-
-# Fixed in next release: https://github.com/snapframework/snap-core/commit/49a8090d7834a0ef9b438048e96be36e55b2fbf5
-RESTRICT=test # test relied on headers ordering
-
-RDEPEND=">=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
- >=dev-haskell/bytestring-builder-0.10.4:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
- >=dev-haskell/case-insensitive-1.1:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
- >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
- >=dev-haskell/hashable-1.2.0.6:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
- >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
- >=dev-haskell/io-streams-1.3:=[zlib,profile?] <dev-haskell/io-streams-1.6:=[zlib,profile?]
- >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
- >=dev-haskell/monad-control-1.0:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
- >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-3.2:=[profile?]
- >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?]
- >=dev-haskell/random-1:=[profile?] <dev-haskell/random-2:=[profile?]
- >=dev-haskell/readable-0.1:=[profile?] <dev-haskell/readable-0.4:=[profile?]
- >=dev-haskell/regex-posix-0.95:=[profile?] <dev-haskell/regex-posix-1:=[profile?]
- >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
- >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
- >=dev-haskell/transformers-base-0.4:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
- >=dev-haskell/unix-compat-0.3:=[profile?] <dev-haskell/unix-compat-0.6:=[profile?]
- >=dev-haskell/unordered-containers-0.1.4.3:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
- >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.13:=[profile?]
- >=dev-lang/ghc-7.8.2:=
- portable? ( >=dev-haskell/time-locale-compat-0.1:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?] )
- !portable? ( >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( >=dev-haskell/parallel-3 <dev-haskell/parallel-4
- >=dev-haskell/quickcheck-2.3.0.2 <dev-haskell/quickcheck-3
- >=dev-haskell/test-framework-0.8.0.3 <dev-haskell/test-framework-0.9
- >=dev-haskell/test-framework-hunit-0.2.7 <dev-haskell/test-framework-hunit-0.4
- >=dev-haskell/test-framework-quickcheck2-0.2.12.1 <dev-haskell/test-framework-quickcheck2-0.4
- >=dev-haskell/zlib-0.5 <dev-haskell/zlib-0.7 )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag debug debug) \
- --flag=network-uri \
- $(cabal_flag portable portable)
-}