summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/splitmix')
-rw-r--r--dev-haskell/splitmix/Manifest1
-rw-r--r--dev-haskell/splitmix/metadata.xml5
-rw-r--r--dev-haskell/splitmix/splitmix-0.0.4.ebuild33
3 files changed, 2 insertions, 37 deletions
diff --git a/dev-haskell/splitmix/Manifest b/dev-haskell/splitmix/Manifest
index bf50d4a3b1c9..b67e7c5f0d28 100644
--- a/dev-haskell/splitmix/Manifest
+++ b/dev-haskell/splitmix/Manifest
@@ -1,2 +1 @@
-DIST splitmix-0.0.4.tar.gz 13821 BLAKE2B 15c2f3b783b98deccf31e2501ba6c67788047ad3bf5c29fbba965c1163506d0055e94bc02894f17df088e67921447893f42a85f5eece7828625d75c177837f43 SHA512 9b8c137067497b94a460d024e1f7c3269e27536f505649face85748a0aaea273d32893a806d9ecf551bd29532ed820004ed2dde47e1099afc3c31519ea5cdbac
DIST splitmix-0.1.0.3.tar.gz 20754 BLAKE2B b9eecbdc2f05361aaa852afd8f6b0c6ca220b2d09e0a0d598796636ace0f995c39defb6d84c6c3ed1bba2e3822ef1bf48f2f34d5ac4406031c4ae5b6cf6d0824 SHA512 22a3f0759e1c1150aabde01a77b48087509dfc7ff9614e97e5e06af73f533170993ff2e18101d940e7ddba81b8d6e496795be3851fccfa07b75e9d922f325064
diff --git a/dev-haskell/splitmix/metadata.xml b/dev-haskell/splitmix/metadata.xml
index e03ae875fc0c..80f38d62e4f5 100644
--- a/dev-haskell/splitmix/metadata.xml
+++ b/dev-haskell/splitmix/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="optimised-mixer">Use JavaScript for mix32</flag>
- <flag name="random">Providen RandomGen SMGen instance</flag>
</use>
<longdescription>
Pure Haskell implementation of SplitMix described in
@@ -15,7 +14,7 @@
Guy L. Steele, Jr., Doug Lea, and Christine H. Flood. 2014.
Fast splittable pseudorandom number generators. In Proceedings
of the 2014 ACM International Conference on Object Oriented
- Programming Systems Languages &amp; Applications (OOPSLA '14). ACM,
+ Programming Systems Languages &amp; Applications (OOPSLA &#39;14). ACM,
New York, NY, USA, 453-472. DOI:
&lt;https://doi.org/10.1145/2660193.2660195&gt;
@@ -25,7 +24,7 @@
/SplitMix/ is tested with two standard statistical test suites (DieHarder and
TestU01, this implementation only using the former) and it appears to be
- adequate for "everyday" use, such as Monte Carlo algorithms and randomized
+ adequate for &quot;everyday&quot; use, such as Monte Carlo algorithms and randomized
data structures where speed is important.
In particular, it __should not be used for cryptographic or security applications__,
diff --git a/dev-haskell/splitmix/splitmix-0.0.4.ebuild b/dev-haskell/splitmix/splitmix-0.0.4.ebuild
deleted file mode 100644
index c658af591847..000000000000
--- a/dev-haskell/splitmix/splitmix-0.0.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.4
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # circular deps: test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Fast Splittable PRNG"
-HOMEPAGE="https://hackage.haskell.org/package/splitmix"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="optimised-mixer +random"
-
-RESTRICT=test # circular deps: dev-haskell/splitmix[test]->dev-haskell/base-compat-batteries->dev-haskell/quickcheck->dev-haskell/splitmix
-
-RDEPEND=">=dev-lang/ghc-7.4.1:=
- random? ( >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag optimised-mixer optimised-mixer) \
- $(cabal_flag random random)
-}