summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/streaming-commons/streaming-commons-0.2.2.5.ebuild')
-rw-r--r--dev-haskell/streaming-commons/streaming-commons-0.2.2.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/streaming-commons/streaming-commons-0.2.2.5.ebuild b/dev-haskell/streaming-commons/streaming-commons-0.2.2.5.ebuild
new file mode 100644
index 000000000000..a923bb975e81
--- /dev/null
+++ b/dev-haskell/streaming-commons/streaming-commons-0.2.2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Common lower-level functions needed by various streaming data libraries"
+HOMEPAGE="https://github.com/fpco/streaming-commons"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-haskell/async:=[profile?]
+ >=dev-haskell/network-2.4.0.0:=[profile?]
+ || ( dev-lang/ghc dev-haskell/process[profile?] )
+ dev-haskell/random:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-8.6.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4.0.1
+ test? (
+ >=dev-haskell/hspec-1.8
+ dev-haskell/quickcheck
+ )
+"