summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/tasty-rerun/tasty-rerun-1.1.18.ebuild')
-rw-r--r--dev-haskell/tasty-rerun/tasty-rerun-1.1.18.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/tasty-rerun/tasty-rerun-1.1.18.ebuild b/dev-haskell/tasty-rerun/tasty-rerun-1.1.18.ebuild
new file mode 100644
index 000000000000..82ca28d9f6a0
--- /dev/null
+++ b/dev-haskell/tasty-rerun/tasty-rerun-1.1.18.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Rerun only tests which failed in a previous test run"
+HOMEPAGE="https://github.com/ocharles/tasty-rerun"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.1.2:=[profile?]
+ >=dev-haskell/optparse-applicative-0.6:=[profile?]
+ >=dev-haskell/split-0.1:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/stm-2.4.2:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/tasty-1.2:=[profile?] <dev-haskell/tasty-1.5:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_prepare() {
+ default
+ cabal_chdeps \
+ 'base >=4.6 && <4.15' 'base >=4.6'
+}