summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/temporary')
-rw-r--r--dev-haskell/temporary/Manifest3
-rw-r--r--dev-haskell/temporary/files/temporary-1.3-smp-flag.patch46
-rw-r--r--dev-haskell/temporary/metadata.xml13
-rw-r--r--dev-haskell/temporary/temporary-1.1.2.4.ebuild27
-rw-r--r--dev-haskell/temporary/temporary-1.2.0.3.ebuild26
-rw-r--r--dev-haskell/temporary/temporary-1.2.0.4.ebuild26
-rw-r--r--dev-haskell/temporary/temporary-1.3-r1.ebuild44
-rw-r--r--dev-haskell/temporary/temporary-1.3.ebuild8
8 files changed, 98 insertions, 95 deletions
diff --git a/dev-haskell/temporary/Manifest b/dev-haskell/temporary/Manifest
index 07539175700b..7ab639b8eb2b 100644
--- a/dev-haskell/temporary/Manifest
+++ b/dev-haskell/temporary/Manifest
@@ -1,4 +1 @@
-DIST temporary-1.1.2.4.tar.gz 5220 BLAKE2B dc5744b92fb2b20a878becbc4c4a5274e8d6ae9d827abfa30333f5f30ba0ac8141c7cf8805de532e241d7379f3fdbe8900a18c471d0405cbedf85c817d1f026c SHA512 ebd2221ed75deba8c411ef4e4c6c45de41beaa1d26521f488b4ab16ee731839cd6193ce987701a224110451138c4eeb1b40d01a65a20b4508bc9fbd2a87e7313
-DIST temporary-1.2.0.3.tar.gz 5308 BLAKE2B 5c570641d27bbda5f28a1f0eac65a89377310cf10f1188b3bb90f5ec0aba67c466f3518a69dc4f1e446031c3e6f6fa6fce65f705db0185401d0986b385072d60 SHA512 ceada89c2166c315b2a54cae0a636eb0b38e6e89481ef32d3d1e4305d4e601305b4cb88fba3069493e8fe2014e3d237348a37567aba61e617c69707f0a16dd34
-DIST temporary-1.2.0.4.tar.gz 5347 BLAKE2B bf1d5740510248d993159aa4e1fba4c023efe1f64e8160c4a6ed33c2f8529907a406600c096f9ea0954f8f635955d2ba47968346f4c62eb3037f6748c862a9f7 SHA512 cc8ba1c43d3e75f13450cbbbea081b5dd42d4a8c0fd33dd4ca9cec636aa91c2cd5c6edbcd86bf7895d6672a46c3e2c8edc57bb2ce88f61fdc05ec75e62c9373f
DIST temporary-1.3.tar.gz 5686 BLAKE2B 7769c471a8fe3f2a73291b53633c9d4ec785bff9dfa93874f46bdac50b7e16a5fea918848645132593d2d0c0aeda2479777e04b1adf8fa501306bace89fdfdcd SHA512 e3078caf54da95c4efa9e9c936b35a98b62296ecce2242cd4e103605a9d29e8a9d6c7027dbf50d02b6a893bea558ea5b07dbb1df7c59bf26d86db76ccf112f25
diff --git a/dev-haskell/temporary/files/temporary-1.3-smp-flag.patch b/dev-haskell/temporary/files/temporary-1.3-smp-flag.patch
new file mode 100644
index 000000000000..22832a87777a
--- /dev/null
+++ b/dev-haskell/temporary/files/temporary-1.3-smp-flag.patch
@@ -0,0 +1,46 @@
+From 7f448b41589fccd3ac883c6fb3865f8dbedcb14d Mon Sep 17 00:00:00 2001
+From: hololeap <hololeap@users.noreply.github.com>
+Date: Sun, 30 Oct 2022 12:45:29 -0600
+Bug: https://github.com/UnkindPartition/temporary/pull/15
+Subject: [PATCH] Add smp flag
+
+This flag will toggle the use of some `ghc-options` in the test suite.
+It is set to `default: True`.
+
+This is needed for tests to run on some GHC builds which do not support
+a threaded runtime.
+
+Reported-by: matoro <https://github.com/matoro>
+Signed-off-by: hololeap <hololeap@users.noreply.github.com>
+---
+ temporary.cabal | 10 +++++++++-
+ 1 file changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/temporary.cabal b/temporary.cabal
+index 67163d1..ca54604 100644
+--- a/temporary.cabal
++++ b/temporary.cabal
+@@ -15,6 +15,11 @@ source-repository head
+ type: git
+ location: git://github.com/feuerbach/temporary.git
+
++flag smp
++ description: Use flags that depend on GHC supporting a multicore runtime (tests only)
++ manual: True
++ default: True
++
+ Library
+ default-language:
+ Haskell2010
+@@ -37,7 +42,10 @@ test-suite test
+ tests
+ main-is:
+ test.hs
+- ghc-options: -threaded -with-rtsopts=-N2
++ if flag(smp)
++ ghc-options: -threaded -with-rtsopts=-N2
++ else
++ ghc-options: -threaded
+ build-depends:
+ base >= 4.3 && < 5
+ , directory
diff --git a/dev-haskell/temporary/metadata.xml b/dev-haskell/temporary/metadata.xml
index dd1a1cb7cec3..5a2f1de5b5d4 100644
--- a/dev-haskell/temporary/metadata.xml
+++ b/dev-haskell/temporary/metadata.xml
@@ -1,17 +1,12 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The functions for creating temporary files and directories in the base library are quite limited. The unixutils
- package contains some good ones, but they aren't portable to Windows.
- This library just repackages the Cabal implementations of its own temporary file and folder functions so that
- you can use them without linking against Cabal or depending on it being installed.
- </longdescription>
<upstream>
- <remote-id type="github">batterseapower/temporary</remote-id>
+ <remote-id type="hackage">temporary</remote-id>
+ <remote-id type="github">feuerbach/temporary</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/temporary/temporary-1.1.2.4.ebuild b/dev-haskell/temporary/temporary-1.1.2.4.ebuild
deleted file mode 100644
index c0bbd705484e..000000000000
--- a/dev-haskell/temporary/temporary-1.1.2.4.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Portable temporary file and directory support for Windows and Unix"
-HOMEPAGE="https://github.com/batterseapower/temporary"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-6.10.4:="
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
-
-src_prepare() {
- cabal_chdeps \
- 'unix >= 2.3 && < 2.7' 'unix >= 2.3'
-}
diff --git a/dev-haskell/temporary/temporary-1.2.0.3.ebuild b/dev-haskell/temporary/temporary-1.2.0.3.ebuild
deleted file mode 100644
index 18c1ee7e611c..000000000000
--- a/dev-haskell/temporary/temporary-1.2.0.3.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Portable temporary file and directory support for Windows and Unix"
-HOMEPAGE="https://github.com/batterseapower/temporary"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/exceptions-0.6:=[profile?]
- >=dev-haskell/transformers-0.2.0.0:=[profile?]
- >=dev-lang/ghc-6.10.4:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6.0.3
-"
diff --git a/dev-haskell/temporary/temporary-1.2.0.4.ebuild b/dev-haskell/temporary/temporary-1.2.0.4.ebuild
deleted file mode 100644
index 4f76a17ee7cd..000000000000
--- a/dev-haskell/temporary/temporary-1.2.0.4.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Portable temporary file and directory support for Windows and Unix"
-HOMEPAGE="http://www.github.com/feuerbach/temporary"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND=">=dev-haskell/exceptions-0.6:=[profile?]
- >=dev-haskell/transformers-0.2.0.0:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6
-"
diff --git a/dev-haskell/temporary/temporary-1.3-r1.ebuild b/dev-haskell/temporary/temporary-1.3-r1.ebuild
new file mode 100644
index 000000000000..604644669b27
--- /dev/null
+++ b/dev-haskell/temporary/temporary-1.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit ghc-package haskell-cabal
+
+DESCRIPTION="Portable temporary file and directory support"
+HOMEPAGE="https://github.com/feuerbach/temporary"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3-smp-flag.patch"
+)
+
+RDEPEND="
+ >=dev-haskell/random-1.1:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? (
+ dev-haskell/base-compat
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ )
+"
+
+src_configure() {
+ if ghc-supports-smp; then
+ local smp_flag=smp
+ else
+ local smp_flag=-smp
+ fi
+
+ haskell-cabal_src_configure \
+ --flag="${smp_flag}"
+}
diff --git a/dev-haskell/temporary/temporary-1.3.ebuild b/dev-haskell/temporary/temporary-1.3.ebuild
index 1557b635b0ea..3bbb3ee7db6b 100644
--- a/dev-haskell/temporary/temporary-1.3.ebuild
+++ b/dev-haskell/temporary/temporary-1.3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ebuild generated by hackport 0.6.9999
@@ -9,12 +9,12 @@ CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Portable temporary file and directory support for Windows and Unix"
-HOMEPAGE="https://github.com/feuerbach/temporary"
+HOMEPAGE="https://github.com/UnkindPartition/temporary"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE=""
RDEPEND=">=dev-haskell/exceptions-0.6:=[profile?]