summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/text/text-1.2.2.0.ebuild')
-rw-r--r--dev-haskell/text/text-1.2.2.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/text/text-1.2.2.0.ebuild b/dev-haskell/text/text-1.2.2.0.ebuild
new file mode 100644
index 000000000000..42ba63d8d714
--- /dev/null
+++ b/dev-haskell/text/text-1.2.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -developer,-integer-pure
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type"
+HOMEPAGE="https://github.com/bos/text"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RESTRICT=test # break cyclic dependencies
+
+RDEPEND="dev-haskell/binary:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.7
+ dev-haskell/quickcheck-unicode
+ dev-haskell/random
+ >=dev-haskell/test-framework-0.4
+ >=dev-haskell/test-framework-hunit-0.2
+ >=dev-haskell/test-framework-quickcheck2-0.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer \
+ --flag=-integer-pure
+}