summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/text/text-1.2.3.1.ebuild')
-rw-r--r--dev-haskell/text/text-1.2.3.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/text/text-1.2.3.1.ebuild b/dev-haskell/text/text-1.2.3.1.ebuild
new file mode 100644
index 000000000000..9bc3d4248bb2
--- /dev/null
+++ b/dev-haskell/text/text-1.2.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.6.9999
+#hackport: flags: -bytestring-builder,-developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # broken test-suite
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type"
+HOMEPAGE="https://github.com/haskell/text"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.6
+#KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+# break cyclic dependencies, test suite requires porting to >=QC-2.11
+RESTRICT=test
+
+RDEPEND=">=dev-lang/ghc-7.8.2:="
+
+DEPEND="${RDEPEND}
+"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.4.4 PM:8.6.1 PM:8.6.2 PM:8.6.3 PM:8.6.4 PM:8.6.5 PM:8.10.1_alpha1 PM:8.10.1_alpha2 PM:9999"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bytestring-builder \
+ --flag=-developer \
+ --flag=-integer-simple
+}