summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/tls/tls-1.3.4.ebuild')
-rw-r--r--dev-haskell/tls/tls-1.3.4.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-haskell/tls/tls-1.3.4.ebuild b/dev-haskell/tls/tls-1.3.4.ebuild
deleted file mode 100644
index 70448327f8d3..000000000000
--- a/dev-haskell/tls/tls-1.3.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.6.9999
-#hackport: flags: -hans
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
-HOMEPAGE="https://github.com/vincenthz/hs-tls"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+compat +network"
-
-RDEPEND="dev-haskell/asn1-encoding:=[profile?]
- >=dev-haskell/asn1-types-0.2.0:=[profile?]
- dev-haskell/async:=[profile?]
- >=dev-haskell/cereal-0.4:=[profile?]
- >=dev-haskell/cryptonite-0.7:=[profile?]
- dev-haskell/data-default-class:=[profile?]
- dev-haskell/memory:=[profile?]
- >=dev-haskell/mtl-2:=[profile?]
- dev-haskell/transformers:=[profile?]
- >=dev-haskell/x509-1.6.2:=[profile?] <dev-haskell/x509-1.7.0:=[profile?]
- >=dev-haskell/x509-store-1.6:=[profile?]
- >=dev-haskell/x509-validation-1.6.3:=[profile?] <dev-haskell/x509-validation-1.7.0:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- network? ( dev-haskell/network:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( dev-haskell/hourglass
- dev-haskell/quickcheck
- dev-haskell/tasty
- dev-haskell/tasty-quickcheck )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag compat compat) \
- --flag=-hans \
- $(cabal_flag network network)
-}