summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/unicode-collation')
-rw-r--r--dev-haskell/unicode-collation/Manifest2
-rw-r--r--dev-haskell/unicode-collation/metadata.xml17
-rw-r--r--dev-haskell/unicode-collation/unicode-collation-0.1.3.3.ebuild35
-rw-r--r--dev-haskell/unicode-collation/unicode-collation-0.1.3.4.ebuild37
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-haskell/unicode-collation/Manifest b/dev-haskell/unicode-collation/Manifest
new file mode 100644
index 000000000000..e5b667df1be1
--- /dev/null
+++ b/dev-haskell/unicode-collation/Manifest
@@ -0,0 +1,2 @@
+DIST unicode-collation-0.1.3.3.tar.gz 2056081 BLAKE2B 1b5d58b852ff457b4c794d6e8c87c0539a5987240c2cdb8329fbb00b792be1105c194b55a10b5abd9c59eac7262194065d460a18e994edd2d7f71f535acb4f41 SHA512 bbb8fb3d52fa4906ddb92fb605f49b4c726cfcffd1f950c8a78bc495594a2e7d85fa78e2009da850f0218fce09a57f829ce0f3d6a6000b9b6484754f8c8260e8
+DIST unicode-collation-0.1.3.4.tar.gz 2056084 BLAKE2B e960e740aacd61dfde76fd1ea6da0e50319f91a5b9ea97d3ab95514bf13fd35957ed1b9d3883b980e488d1ef19fce2efda83aad68bc9cd83c5de9d6f3c23519f SHA512 88017dd6d8a96b4248fe993385bad8a5fbe134bdaab05b1f8956bc53c8abba927e22233eed6e3a1760c5cee928a9b2fc74bdb5c0c2c7be7e98bda0049852aec0
diff --git a/dev-haskell/unicode-collation/metadata.xml b/dev-haskell/unicode-collation/metadata.xml
new file mode 100644
index 000000000000..dc3a9336a589
--- /dev/null
+++ b/dev-haskell/unicode-collation/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="doctests">Run doctests as part of test suite.
+Use with: @--write-ghc-environment-files=always@.</flag>
+ <flag name="executable">Build the unicode-collate executable.</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">unicode-collation</remote-id>
+ <remote-id type="github">jgm/unicode-collation</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/unicode-collation/unicode-collation-0.1.3.3.ebuild b/dev-haskell/unicode-collation/unicode-collation-0.1.3.3.ebuild
new file mode 100644
index 000000000000..dcaaa9e2cc75
--- /dev/null
+++ b/dev-haskell/unicode-collation/unicode-collation-0.1.3.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell implementation of the Unicode Collation Algorithm"
+HOMEPAGE="https://github.com/jgm/unicode-collation"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doctests executable"
+
+RDEPEND="dev-haskell/th-lift-instances:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ >=dev-haskell/unicode-transforms-0.3.7.1
+ doctests? ( >=dev-haskell/doctest-0.8 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag doctests doctests) \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/unicode-collation/unicode-collation-0.1.3.4.ebuild b/dev-haskell/unicode-collation/unicode-collation-0.1.3.4.ebuild
new file mode 100644
index 000000000000..de116d72f284
--- /dev/null
+++ b/dev-haskell/unicode-collation/unicode-collation-0.1.3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell implementation of the Unicode Collation Algorithm"
+HOMEPAGE="https://github.com/jgm/unicode-collation"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doctests executable"
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ dev-haskell/th-lift-instances:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ >=dev-haskell/unicode-transforms-0.3.7.1
+ doctests? ( >=dev-haskell/doctest-0.8 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag doctests doctests) \
+ $(cabal_flag executable executable)
+}