summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/unix-compat/unix-compat-0.7.ebuild')
-rw-r--r--dev-haskell/unix-compat/unix-compat-0.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/unix-compat/unix-compat-0.7.ebuild b/dev-haskell/unix-compat/unix-compat-0.7.ebuild
new file mode 100644
index 000000000000..ce0ef908850d
--- /dev/null
+++ b/dev-haskell/unix-compat/unix-compat-0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Portable POSIX-compatibility layer"
+HOMEPAGE="https://github.com/haskell-pkg-janitors/unix-compat"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="old-time"
+
+RDEPEND=">=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( dev-haskell/extra
+ dev-haskell/hspec
+ dev-haskell/hunit
+ dev-haskell/monad-parallel
+ dev-haskell/temporary )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag old-time old-time)
+}