summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/unliftio')
-rw-r--r--dev-haskell/unliftio/Manifest3
-rw-r--r--dev-haskell/unliftio/metadata.xml6
-rw-r--r--dev-haskell/unliftio/unliftio-0.2.18.ebuild (renamed from dev-haskell/unliftio/unliftio-0.2.12.1.ebuild)13
-rw-r--r--dev-haskell/unliftio/unliftio-0.2.23.0-r1.ebuild31
4 files changed, 44 insertions, 9 deletions
diff --git a/dev-haskell/unliftio/Manifest b/dev-haskell/unliftio/Manifest
index 855bad213f2a..f138ee3ddeb0 100644
--- a/dev-haskell/unliftio/Manifest
+++ b/dev-haskell/unliftio/Manifest
@@ -1 +1,2 @@
-DIST unliftio-0.2.12.1.tar.gz 53520 BLAKE2B a8f1e044400a5cc49af3db66fe3e79f8441b2a742e11493eddb59bedba94a196591ef914c5ab1cf998f337751fcc931c92e20efc62ef7989d460072cb44abb96 SHA512 fb2814860cd2b59ae1a17dfb5892198666b59b737264e46e303909a9f5ce2377f92e70ab7d666fc7f927b9cad6593659dd2bb2168478021927b184e54ae4b44d
+DIST unliftio-0.2.18.tar.gz 56344 BLAKE2B 7e1ae3356ceef94bd50f9dc14c30ee980834cfecfb17ac36233a2e8da7d8564f8671c77b848726ebae5cfc5d81c9c65d6847015956298e2d9bb1aad9479303bd SHA512 baa90de754474bcd7e2116f4f2a5c98192f2cc62368895eda5995b528c193d07225f1f1409b0f24ce24f7ea396237563b2ff8182636b53618d4048d558d1a8fd
+DIST unliftio-0.2.23.0.tar.gz 57461 BLAKE2B 1dc1094e78a25940e0d978dcd723752e00d8f8bb5e8a3c0710fb5d59814c1cf67350f20b6e682644113ba993d9782eff63bfab507830adcebabfc707c8006dfc SHA512 24c06ab66c88a4f6d23376178d484da4a815f77f81b47ec4120b32a45f9d09ca1f4ee89c9ad35a538482aaf68a64155c129f4aef985960869b2dd7387693c449
diff --git a/dev-haskell/unliftio/metadata.xml b/dev-haskell/unliftio/metadata.xml
index b7878815d80d..1f69a776f334 100644
--- a/dev-haskell/unliftio/metadata.xml
+++ b/dev-haskell/unliftio/metadata.xml
@@ -1,8 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">unliftio</remote-id>
+ <remote-id type="github">fpco/unliftio</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/unliftio/unliftio-0.2.12.1.ebuild b/dev-haskell/unliftio/unliftio-0.2.18.ebuild
index 73a601914874..3ec95dacdb6a 100644
--- a/dev-haskell/unliftio/unliftio-0.2.12.1.ebuild
+++ b/dev-haskell/unliftio/unliftio-0.2.18.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.4
+# ebuild generated by hackport 0.6.7.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -14,16 +14,15 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">dev-haskell/async-2.1.1:=[profile?]
>=dev-haskell/stm-2.4.3:=[profile?]
>=dev-haskell/unliftio-core-0.1.1.0:=[profile?]
- >=dev-lang/ghc-7.10.1:=
+ >=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.22.2.0
+ >=dev-haskell/cabal-2.2.0.1
test? ( dev-haskell/hspec
dev-haskell/quickcheck )
"
diff --git a/dev-haskell/unliftio/unliftio-0.2.23.0-r1.ebuild b/dev-haskell/unliftio/unliftio-0.2.23.0-r1.ebuild
new file mode 100644
index 000000000000..2adc79694a80
--- /dev/null
+++ b/dev-haskell/unliftio/unliftio-0.2.23.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="The MonadUnliftIO typeclass for unlifting monads to IO (batteries included)"
+HOMEPAGE="https://github.com/fpco/unliftio/tree/master/unliftio#readme"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-haskell/async-2.1.1:=[profile?]
+ dev-haskell/safe-exceptions:=[profile?]
+ >=dev-haskell/stm-2.5:=[profile?]
+ >=dev-haskell/unliftio-core-0.1.1.0:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ dev-haskell/hspec
+ dev-haskell/quickcheck
+ )
+"