summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/unordered-containers/unordered-containers-0.2.10.0.ebuild')
-rw-r--r--dev-haskell/unordered-containers/unordered-containers-0.2.10.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/unordered-containers/unordered-containers-0.2.10.0.ebuild b/dev-haskell/unordered-containers/unordered-containers-0.2.10.0.ebuild
new file mode 100644
index 000000000000..20e3233ceac9
--- /dev/null
+++ b/dev-haskell/unordered-containers/unordered-containers-0.2.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Drop test-suite: circular depends
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient hashing-based container types"
+HOMEPAGE="https://github.com/tibbe/unordered-containers"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RESTRICT=test # circular deps: unordered-containers[test]->quickcheck->semigroups->unordered-containers
+
+RDEPEND=">=dev-haskell/hashable-1.0.1.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug)
+}