summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/unordered-containers/unordered-containers-0.2.19.1.ebuild')
-rw-r--r--dev-haskell/unordered-containers/unordered-containers-0.2.19.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/unordered-containers/unordered-containers-0.2.19.1.ebuild b/dev-haskell/unordered-containers/unordered-containers-0.2.19.1.ebuild
new file mode 100644
index 000000000000..c750b2627d64
--- /dev/null
+++ b/dev-haskell/unordered-containers/unordered-containers-0.2.19.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+#hackport: flags: -debug
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient hashing-based container types"
+HOMEPAGE="https://github.com/haskell-unordered-containers/unordered-containers"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/hashable-1.2.5:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? (
+ dev-haskell/chasingbottoms
+ dev-haskell/hunit
+ >=dev-haskell/nothunks-0.1.3
+ >=dev-haskell/quickcheck-2.4.0.1
+ dev-haskell/random
+ >=dev-haskell/tasty-1.4.0.3
+ >=dev-haskell/tasty-hunit-0.10.0.3
+ >=dev-haskell/tasty-quickcheck-0.10.1.2
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-debug
+}