summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/uuid-types/uuid-types-1.0.5-r1.ebuild')
-rw-r--r--dev-haskell/uuid-types/uuid-types-1.0.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/uuid-types/uuid-types-1.0.5-r1.ebuild b/dev-haskell/uuid-types/uuid-types-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..5f189b66a425
--- /dev/null
+++ b/dev-haskell/uuid-types/uuid-types-1.0.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.1.9999
+
+CABAL_HACKAGE_REVISION=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Type definitions for Universally Unique Identifiers"
+HOMEPAGE="https://github.com/haskell-hvr/uuid"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ || (
+ ( >=dev-haskell/text-1.2.3.0 <dev-haskell/text-1.3 )
+ ( >=dev-haskell/text-2.0 <dev-haskell/text-2.1 )
+ )
+ dev-haskell/text:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/ghc-byteorder-4.11 <dev-haskell/ghc-byteorder-4.12
+ >=dev-haskell/quickcheck-2.14.2 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-1.4.0.1 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11
+ )
+"