summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/vector-algorithms')
-rw-r--r--dev-haskell/vector-algorithms/Manifest6
-rw-r--r--dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch44
-rw-r--r--dev-haskell/vector-algorithms/metadata.xml15
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.6.0.4.ebuild40
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild40
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.8.0.4.ebuild (renamed from dev-haskell/vector-algorithms/vector-algorithms-0.8.0.3.ebuild)12
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.9.0.1-r1.ebuild49
7 files changed, 66 insertions, 140 deletions
diff --git a/dev-haskell/vector-algorithms/Manifest b/dev-haskell/vector-algorithms/Manifest
index 95ffba10192d..a0704f6820b1 100644
--- a/dev-haskell/vector-algorithms/Manifest
+++ b/dev-haskell/vector-algorithms/Manifest
@@ -1,3 +1,3 @@
-DIST vector-algorithms-0.6.0.4.tar.gz 20455 BLAKE2B 0d0c4ef7ed8996d1ebe65971a451d4cb49118faedbf9cb4a987afb281adf563808778a689df608d2fb3c8fe9398af995d1c5e31cc89fd4f2075c2ebdd7ca4277 SHA512 5e99a77771831f0b9a4485f48aa7be5f5928e811512f0a68e18fa65ecace185dfea74ec09037b05d56e1a9208d2cdbcfed94ce2678d504f6d12267496a3616bf
-DIST vector-algorithms-0.7.0.1.tar.gz 25435 BLAKE2B f9cb3bf592316c92bff4313d264370cc35d62c64e7dec6f14ee9954c0fc12f573e799172793501e1b4f9c556fa1ea8e3db1ac3381ff71bb143e33520c69c18b8 SHA512 1ea718eeb062defee830fa7dba323981678691c5d320b8929dcd695af17f82d65007cfd35103310026dab51cf10462dbead09082fc0ba5ddd0c2e18e305c4c6a
-DIST vector-algorithms-0.8.0.3.tar.gz 26559 BLAKE2B 7541d141967faf4bc1b33dcd23f283e1a6868f0b51e784918c1516a46c38ba3e9205045c87679738d89c48fee3ee2e61286eab59cc66ec8cfc18f1a4b977c634 SHA512 45311e19a1e5c9994e7d666b73445d11946f60915df3d2f385a435538d1b6b0929b56a960f83c5df1b2df883566e7f8e6fdd5be4e075364d7daecd6dbec780e5
+DIST vector-algorithms-0.8.0.4.tar.gz 26681 BLAKE2B fde5a8a9663e5e94e340f4edb1c1d17a47e7b561013982b5bf7711fe595913280476de629470ec9a049a6bd277587b1dc5390ec9e6dd0d7da87eb7f48ab891c8 SHA512 da5f52493c7f68df0a2c718724dcac9be758b09b14c8fa913aa328ee4c1286893fb239882018202d0fcd56709364ccddf3d620ff3b886d830102ef52a0868d42
+DIST vector-algorithms-0.9.0.1-rev1.cabal 3670 BLAKE2B ebb640235c30c3689dc4abe7e5978b435f6f3adb481b595f6ea8d3e702902fc815a07a7cf3569e1a7f82e25a9553bc0432a9897e39626a0813987bbc6947bffb SHA512 1cd195b4ea8c8245d832107c8fb3a58998b461a3973affce983ba802e300d05e8b45c58836d5623073cd4395c196a0d43f1c9648e834cb0d7c4aebf9e97409fd
+DIST vector-algorithms-0.9.0.1.tar.gz 29149 BLAKE2B 4d1e713845c311ca6eea96ad6f42ee53e4fc115b5abe77fd582c5904e3fe8c6c6006a5f4adb0353919931b8f9c99aed812128bca36362e9571d4848ac00a7af6 SHA512 007a0aeac87ca6596cae0f67e8ab5cd3ac4120df940dd221745d86c6500fa1e732d6096248ba613472c57825283cae6a2d67d2d2a5a652496f9ad17c91f9b620
diff --git a/dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch b/dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch
deleted file mode 100644
index 3616dd76d82c..000000000000
--- a/dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/tests/properties/Tests.hs b/tests/properties/Tests.hs
-index a0b7d35..8fcfd36 100644
---- a/tests/properties/Tests.hs
-+++ b/tests/properties/Tests.hs
-@@ -1,2 +1,2 @@
--{-# LANGUAGE ImpredicativeTypes, RankNTypes, TypeOperators, FlexibleContexts #-}
-+{-# LANGUAGE ImpredicativeTypes, RankNTypes, TypeOperators, FlexibleContexts, ScopedTypeVariables #-}
-
-@@ -44,4 +44,4 @@ args = stdArgs
-
--check_Int_sort = forM_ algos $ \(name,algo) ->
-- quickCheckWith args (label name . prop_fullsort algo)
-+check_Int_sort = forM_ algos (\(name,algo :: Algo Int ()) ->
-+ quickCheckWith args (label name . prop_fullsort algo))
- where
-@@ -55,4 +55,4 @@ check_Int_sort = forM_ algos $ \(name,algo) ->
-
--check_Int_partialsort = forM_ algos $ \(name,algo) ->
-- quickCheckWith args (label name . prop_partialsort algo)
-+check_Int_partialsort = forM_ algos (\(name,algo :: SizeAlgo Int ()) ->
-+ quickCheckWith args (label name . prop_partialsort algo))
- where
-@@ -63,4 +63,4 @@ check_Int_partialsort = forM_ algos $ \(name,algo) ->
-
--check_Int_select = forM_ algos $ \(name,algo) ->
-- quickCheckWith args (label name . prop_select algo)
-+check_Int_select = forM_ algos (\(name,algo :: SizeAlgo Int ()) ->
-+ quickCheckWith args (label name . prop_select algo))
- where
-@@ -119,10 +119,10 @@ check_permutation = do
- qc $ label "introsort" . prop_permutation (INT.sort :: Algo Int ())
-- qc $ label "intropartial" . prop_sized (const . prop_permutation)
-+ qc $ label "intropartial" . prop_sized (\x -> const (prop_permutation x))
- (INT.partialSort :: SizeAlgo Int ())
-- qc $ label "introselect" . prop_sized (const . prop_permutation)
-+ qc $ label "introselect" . prop_sized (\x -> const (prop_permutation x))
- (INT.select :: SizeAlgo Int ())
- qc $ label "heapsort" . prop_permutation (H.sort :: Algo Int ())
-- qc $ label "heappartial" . prop_sized (const . prop_permutation)
-+ qc $ label "heappartial" . prop_sized (\x -> const (prop_permutation x))
- (H.partialSort :: SizeAlgo Int ())
-- qc $ label "heapselect" . prop_sized (const . prop_permutation)
-+ qc $ label "heapselect" . prop_sized (\x -> const (prop_permutation x))
- (H.select :: SizeAlgo Int ())
diff --git a/dev-haskell/vector-algorithms/metadata.xml b/dev-haskell/vector-algorithms/metadata.xml
index 4a0d9fc89df7..7d5210abf463 100644
--- a/dev-haskell/vector-algorithms/metadata.xml
+++ b/dev-haskell/vector-algorithms/metadata.xml
@@ -1,18 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="bench">Build a benchmarking program.</flag>
- <flag name="boundschecks">Enable bounds checking.</flag>
+ <flag name="bench">Build a benchmarking program to test vector-algorithms performance</flag>
+ <flag name="boundschecks">Enable bounds checking</flag>
<flag name="internalchecks">Enable internal consistency checks at the cost of a significant performance penalty.</flag>
- <flag name="properties">Enable quickcheck tests.</flag>
+ <flag name="properties">Enable the quickcheck tests</flag>
<flag name="unsafechecks">Enable bounds checking in unsafe operations at the cost of a significant performance penalty.</flag>
</use>
- <longdescription>
- Efficient algorithms for vector arrays
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">vector-algorithms</remote-id>
+ <remote-id type="github">erikd/vector-algorithms</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.4.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.4.ebuild
deleted file mode 100644
index 60de2b4a02fb..000000000000
--- a/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Efficient algorithms for vector arrays"
-HOMEPAGE="http://code.haskell.org/~dolio/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="bench +boundschecks internalchecks +properties unsafechecks"
-
-RESTRICT=test # hangs
-
-RDEPEND="dev-haskell/mtl:=[profile?]
- dev-haskell/mwc-random:=[profile?]
- >=dev-haskell/primitive-0.3:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
- >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.11:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.9.2
- test? ( properties? ( >=dev-haskell/quickcheck-2 ) )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag bench bench) \
- $(cabal_flag boundschecks boundschecks) \
- $(cabal_flag internalchecks internalchecks) \
- $(cabal_flag properties properties) \
- $(cabal_flag unsafechecks unsafechecks)
-}
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild
deleted file mode 100644
index 9a143ddec1ca..000000000000
--- a/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.4.6.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Efficient algorithms for vector arrays"
-HOMEPAGE="http://code.haskell.org/~dolio/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="bench +boundschecks internalchecks +properties unsafechecks"
-
-RDEPEND="dev-haskell/mtl:=[profile?]
- dev-haskell/mwc-random:=[profile?]
- >=dev-haskell/primitive-0.3:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
- >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.12:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.9.2
- test? ( properties? ( >=dev-haskell/quickcheck-2 ) )
-"
-
-PATCHES=("${FILESDIR}"/${P}-ghc-8.0.2_rc1.patch)
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag bench bench) \
- $(cabal_flag boundschecks boundschecks) \
- $(cabal_flag internalchecks internalchecks) \
- $(cabal_flag properties properties) \
- $(cabal_flag unsafechecks unsafechecks)
-}
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.8.0.3.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.8.0.4.ebuild
index a1fcf35bd7ab..511e4de77a01 100644
--- a/dev-haskell/vector-algorithms/vector-algorithms-0.8.0.3.ebuild
+++ b/dev-haskell/vector-algorithms/vector-algorithms-0.8.0.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.1
+# ebuild generated by hackport 0.6.7.9999
#hackport: flags: -llvm
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
@@ -15,7 +15,7 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+bench +boundschecks internalchecks +properties unsafechecks"
RDEPEND=">=dev-haskell/primitive-0.3:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
@@ -24,8 +24,8 @@ RDEPEND=">=dev-haskell/primitive-0.3:=[profile?] <dev-haskell/primitive-0.8:=[pr
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.9.2
- test? ( properties? ( >dev-haskell/quickcheck-2.9 <dev-haskell/quickcheck-2.14 ) )
+ >=dev-haskell/cabal-1.10
+ test? ( properties? ( >dev-haskell/quickcheck-2.9 <dev-haskell/quickcheck-2.15 ) )
"
src_configure() {
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.9.0.1-r1.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.9.0.1-r1.ebuild
new file mode 100644
index 000000000000..1bb09c174af8
--- /dev/null
+++ b/dev-haskell/vector-algorithms/vector-algorithms-0.9.0.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+#hackport: flags: -llvm
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient algorithms for vector arrays"
+HOMEPAGE="https://github.com/erikd/vector-algorithms/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+bench +boundschecks internalchecks +properties unsafechecks"
+
+RDEPEND=">=dev-haskell/bitvec-1.0:=[profile?] <dev-haskell/bitvec-1.2:=[profile?]
+ >=dev-haskell/primitive-0.6.2.0:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.14:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+
+# bug 916191
+RDEPEND+="
+ || (
+ dev-haskell/bitvec[gmp]
+ dev-lang/ghc[gmp]
+ )
+"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( properties? ( >dev-haskell/quickcheck-2.9 <dev-haskell/quickcheck-2.15 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bench bench) \
+ $(cabal_flag boundschecks boundschecks) \
+ $(cabal_flag internalchecks internalchecks) \
+ --flag=-llvm \
+ $(cabal_flag properties properties) \
+ $(cabal_flag unsafechecks unsafechecks)
+}