summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/wai-conduit')
-rw-r--r--dev-haskell/wai-conduit/Manifest3
-rw-r--r--dev-haskell/wai-conduit/metadata.xml12
-rw-r--r--dev-haskell/wai-conduit/wai-conduit-3.0.0.1.ebuild30
-rw-r--r--dev-haskell/wai-conduit/wai-conduit-3.0.0.2.ebuild30
-rw-r--r--dev-haskell/wai-conduit/wai-conduit-3.0.0.ebuild30
5 files changed, 105 insertions, 0 deletions
diff --git a/dev-haskell/wai-conduit/Manifest b/dev-haskell/wai-conduit/Manifest
new file mode 100644
index 000000000000..f40315b1fa5a
--- /dev/null
+++ b/dev-haskell/wai-conduit/Manifest
@@ -0,0 +1,3 @@
+DIST wai-conduit-3.0.0.1.tar.gz 1979 SHA256 d543f85df31a2d493d2eac3c43fb658e33f2484b4b5de2d738687d7a4d76b554 SHA512 6e32fcd54e729b14b7a1183b0e340d69d44756a655264193439c1c4e7979f7fdc51cfe0ae5de2434f9805dad210a0779ff8ac93d812f5e74ab72a40b98ff3528 WHIRLPOOL b94207a945e54c578c9224c0a6f83e02b0df4b484bf40d9c056fd52fe3211395a88fd3d1aff16ffa6b42a1c73a17a089f878bf8553d762bf1f062a15df6dfd23
+DIST wai-conduit-3.0.0.2.tar.gz 2139 SHA256 47d2882f3f95edf32cdde9db9c663dcc0bdcee3efd605a673c1f3e80e34216f3 SHA512 2b24acf1148b157375dd9f70a15f07b1fb24e76b8cdaa0e67abc47bf8f181d41ae326beb05c769698bbaff0cedb3211f6c148c323f3ff0e35745a5f05198ae1b WHIRLPOOL 67fafe08c19d04ab40c883ad855dfeb44c0d26407abe724451c01f73a820ee23e0cb9af8df4c55db434ef715cc474c1661c05ff2cd369a50e3894082571ed0c5
+DIST wai-conduit-3.0.0.tar.gz 1987 SHA256 af690912fb471a8a4a59c75b83d256d60c00cc78f3f80f87f407bf38bb97226d SHA512 9dc576ab1276cc4d45bdb709f54f7f24e8d445602f65863f5377e3707debe79352c3aeb4a9b61335feaed30b1b531eb3df23f326b43f2592230e7c65fb223b50 WHIRLPOOL d4ee9a2af8f7fa2655e3abc63e8790f43c10be5215f85fbec5069438c49d1f18f189b53b73e9ebe855769f803f98393f2087539ca292a3c657ee3c4a18e1e45a
diff --git a/dev-haskell/wai-conduit/metadata.xml b/dev-haskell/wai-conduit/metadata.xml
new file mode 100644
index 000000000000..84250b3f450e
--- /dev/null
+++ b/dev-haskell/wai-conduit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Since version 3.0.0, WAI has no built-in streaming data abstraction.
+ This library provides similar functionality to what existed in WAI 2.x.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">yesodweb/wai</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/wai-conduit/wai-conduit-3.0.0.1.ebuild b/dev-haskell/wai-conduit/wai-conduit-3.0.0.1.ebuild
new file mode 100644
index 000000000000..d119ff69b463
--- /dev/null
+++ b/dev-haskell/wai-conduit/wai-conduit-3.0.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="conduit wrappers for WAI"
+HOMEPAGE="https://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/wai-conduit/wai-conduit-3.0.0.2.ebuild b/dev-haskell/wai-conduit/wai-conduit-3.0.0.2.ebuild
new file mode 100644
index 000000000000..74a7bf8ed3ed
--- /dev/null
+++ b/dev-haskell/wai-conduit/wai-conduit-3.0.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="conduit wrappers for WAI"
+HOMEPAGE="https://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/wai-conduit/wai-conduit-3.0.0.ebuild b/dev-haskell/wai-conduit/wai-conduit-3.0.0.ebuild
new file mode 100644
index 000000000000..d119ff69b463
--- /dev/null
+++ b/dev-haskell/wai-conduit/wai-conduit-3.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="conduit wrappers for WAI"
+HOMEPAGE="https://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"