summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/wai-cors/wai-cors-0.2.7.ebuild')
-rw-r--r--dev-haskell/wai-cors/wai-cors-0.2.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/wai-cors/wai-cors-0.2.7.ebuild b/dev-haskell/wai-cors/wai-cors-0.2.7.ebuild
new file mode 100644
index 000000000000..9b040f1530e2
--- /dev/null
+++ b/dev-haskell/wai-cors/wai-cors-0.2.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="CORS for WAI"
+HOMEPAGE="https://github.com/larskuhtz/wai-cors"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RESTRICT=test # one test fails
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.4.0:=[profile?]
+ >=dev-haskell/base-unicode-symbols-0.2.2.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0.0.1:=[profile?]
+ >=dev-haskell/http-types-0.8.0:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( >=dev-haskell/network-2.6
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/text-1.2
+ >=dev-haskell/wai-extra-3.0
+ >=dev-haskell/wai-websockets-3.0.1
+ >=dev-haskell/warp-3.0
+ >=dev-haskell/websockets-0.10 )
+"