summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/wai-extra/wai-extra-3.0.6.1.ebuild')
-rw-r--r--dev-haskell/wai-extra/wai-extra-3.0.6.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/wai-extra/wai-extra-3.0.6.1.ebuild b/dev-haskell/wai-extra/wai-extra-3.0.6.1.ebuild
new file mode 100644
index 000000000000..e51006a8fd93
--- /dev/null
+++ b/dev-haskell/wai-extra/wai-extra-3.0.6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Provides some basic WAI handlers and middleware"
+HOMEPAGE="http://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/ansi-terminal:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/fast-logger-2.1:=[profile?] <dev-haskell/fast-logger-2.4:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/lifted-base-0.1.2:=[profile?]
+ >=dev-haskell/network-2.2.1.5:=[profile?]
+ >=dev-haskell/old-locale-1.0.0.2:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/resourcet-0.4.6:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ >=dev-haskell/stringsearch-0.3:=[profile?] <dev-haskell/stringsearch-0.4:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ >=dev-haskell/void-0.5:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.1:=[profile?]
+ >=dev-haskell/wai-logger-2.0:=[profile?] <dev-haskell/wai-logger-2.3:=[profile?]
+ dev-haskell/word8:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/zlib )
+"