summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/warp-tls/warp-tls-3.4.1.ebuild')
-rw-r--r--dev-haskell/warp-tls/warp-tls-3.4.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/warp-tls/warp-tls-3.4.1.ebuild b/dev-haskell/warp-tls/warp-tls-3.4.1.ebuild
new file mode 100644
index 000000000000..f3b41384b4b8
--- /dev/null
+++ b/dev-haskell/warp-tls/warp-tls-3.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +tls_1_1_3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP over TLS support for Warp via the TLS package"
+HOMEPAGE="https://github.com/yesodweb/wai"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/data-default-class-0.0.1:=[profile?]
+ >=dev-haskell/network-2.2.1:=[profile?]
+ >=dev-haskell/recv-0.1.0:=[profile?] <dev-haskell/recv-0.2.0:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ >=dev-haskell/tls-1.7:=[profile?]
+ >=dev-haskell/tls-session-manager-0.0.4:=[profile?]
+ dev-haskell/unliftio:=[profile?]
+ >=dev-haskell/wai-3.2:=[profile?] <dev-haskell/wai-3.3:=[profile?]
+ >=dev-haskell/warp-3.3.23:=[profile?] <dev-haskell/warp-3.4:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=tls_1_1_3
+}