summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/warp/warp-3.0.13.1.ebuild')
-rw-r--r--dev-haskell/warp/warp-3.0.13.1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-haskell/warp/warp-3.0.13.1.ebuild b/dev-haskell/warp/warp-3.0.13.1.ebuild
deleted file mode 100644
index ecb770eeeb96..000000000000
--- a/dev-haskell/warp/warp-3.0.13.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.5.9999
-#hackport: flags: -network-bytestring
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A fast, light-weight web server for WAI applications"
-HOMEPAGE="https://github.com/yesodweb/wai"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+allow-sendfilefd warp-debug"
-
-# Ambiguous module name ‘Data.IP’: it was found in multiple packages:
-# iproute-1.4.0@ network-data-0.5.3@
-RESTRICT=test
-
-RDEPEND="
- >=dev-haskell/auto-update-0.1.1:=[profile?] <dev-haskell/auto-update-0.2:=[profile?]
- >=dev-haskell/blaze-builder-0.3.3:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
- dev-haskell/bytestring-builder:=[profile?]
- >=dev-haskell/case-insensitive-0.2:=[profile?]
- dev-haskell/http-date:=[profile?]
- >=dev-haskell/http-types-0.8.5:=[profile?]
- >=dev-haskell/iproute-1.3.1:=[profile?]
- >=dev-haskell/network-2.3:=[profile?]
- >=dev-haskell/simple-sendfile-0.2.7:=[profile?] <dev-haskell/simple-sendfile-0.3:=[profile?]
- >=dev-haskell/streaming-commons-0.1.10:=[profile?]
- dev-haskell/text:=[profile?]
- >=dev-haskell/unix-compat-0.2:=[profile?]
- >=dev-haskell/vault-0.3:=[profile?]
- >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.1:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- allow-sendfilefd? ( dev-haskell/hashable:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? (
- dev-haskell/async
- >=dev-haskell/doctest-0.9.3
- >=dev-haskell/hspec-1.3
- dev-haskell/http
- dev-haskell/hunit
- >=dev-haskell/lifted-base-0.1
- dev-haskell/old-locale
- dev-haskell/quickcheck
- >=dev-haskell/transformers-0.2.2
- )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag allow-sendfilefd allow-sendfilefd) \
- --flag=-network-bytestring \
- $(cabal_flag warp-debug warp-debug)
-}