summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/witherable/witherable-0.4.2.ebuild')
-rw-r--r--dev-haskell/witherable/witherable-0.4.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/witherable/witherable-0.4.2.ebuild b/dev-haskell/witherable/witherable-0.4.2.ebuild
new file mode 100644
index 000000000000..4b2fb8645e91
--- /dev/null
+++ b/dev-haskell/witherable/witherable-0.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_HACKAGE_REVISION="2"
+inherit haskell-cabal
+
+DESCRIPTION="filterable traversable"
+HOMEPAGE="https://github.com/fumieval/witherable"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-haskell/base-orphans-0.8.4:=[profile?] <dev-haskell/base-orphans-0.9:=[profile?]
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/indexed-traversable-0.1.1:=[profile?] <dev-haskell/indexed-traversable-0.2:=[profile?]
+ >=dev-haskell/indexed-traversable-instances-0.1:=[profile?] <dev-haskell/indexed-traversable-instances-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.12.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.12.2.0:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4
+ test? ( >=dev-haskell/quickcheck-2.14.2
+ dev-haskell/quickcheck-instances
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${P}-rev${CABAL_HACKAGE_REVISION}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}