summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/wxcore')
-rw-r--r--dev-haskell/wxcore/Manifest1
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.92.2.0-ghc-8.4.patch5
-rw-r--r--dev-haskell/wxcore/files/wxcore-0.92.3.0-cabal-3.patch11
-rw-r--r--dev-haskell/wxcore/metadata.xml14
-rw-r--r--dev-haskell/wxcore/wxcore-0.92.3.0-r1.ebuild53
5 files changed, 0 insertions, 84 deletions
diff --git a/dev-haskell/wxcore/Manifest b/dev-haskell/wxcore/Manifest
deleted file mode 100644
index c63b6baa75ac..000000000000
--- a/dev-haskell/wxcore/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST wxcore-0.92.3.0.tar.gz 400300 BLAKE2B ce7ea6e2ec71935001d0b1fd347d5aa57de5d9f7cab9cf9fa87879c8dfd6291e76811899aeaccf8c227d54e6b0499ea5420dabac84014cbbf6373f8dd8a60f0f SHA512 199eb8afa9b568637c8d1fb2ab8b98a73d4ea9f03df088a855a88f17728997ed1044fb7c1c69d732530d7b24ae312e8dfc3f6ffc0396765d583531524d10a442
diff --git a/dev-haskell/wxcore/files/wxcore-0.92.2.0-ghc-8.4.patch b/dev-haskell/wxcore/files/wxcore-0.92.2.0-ghc-8.4.patch
deleted file mode 100644
index 6c7c2c7e9ce5..000000000000
--- a/dev-haskell/wxcore/files/wxcore-0.92.2.0-ghc-8.4.patch
+++ /dev/null
@@ -1,5 +0,0 @@
---- a/src/haskell/Graphics/UI/WXCore/WxcTypes.hs
-+++ b/src/haskell/Graphics/UI/WXCore/WxcTypes.hs
-@@ -125 +125 @@ import Data.Ix
--import Foreign.C
-+import Foreign.C hiding (CBool)
diff --git a/dev-haskell/wxcore/files/wxcore-0.92.3.0-cabal-3.patch b/dev-haskell/wxcore/files/wxcore-0.92.3.0-cabal-3.patch
deleted file mode 100644
index b93da91f7f43..000000000000
--- a/dev-haskell/wxcore/files/wxcore-0.92.3.0-cabal-3.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Setup.hs
-+++ b/Setup.hs
-@@ -7,7 +7,7 @@ import Data.List (foldl', intersperse, intercalate, nub, lookup, isPrefixOf, isI
- import Data.Maybe (fromJust)
- import Distribution.PackageDescription hiding (includeDirs)
- import qualified Distribution.PackageDescription as PD (includeDirs)
--import Distribution.InstalledPackageInfo(installedPackageId, sourcePackageId, includeDirs)
-+import Distribution.InstalledPackageInfo({-installedPackageId,-} sourcePackageId, includeDirs)
- import Distribution.Simple
- import Distribution.Simple.LocalBuildInfo (LocalBuildInfo, localPkgDescr, installedPkgs, withPrograms, buildDir)
- import Distribution.Simple.PackageIndex(SearchResult (..), searchByName, allPackages )
diff --git a/dev-haskell/wxcore/metadata.xml b/dev-haskell/wxcore/metadata.xml
deleted file mode 100644
index 8c89e4ce4678..000000000000
--- a/dev-haskell/wxcore/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- wxHaskell is a portable and native GUI library for Haskell. It is
- built on top of wxWidgets, a comprehensive C++ library that is
- portable across all major GUI platforms, including GTK, Windows,
- X11, and MacOS X. This version works with wxWidgets 2.8 only.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-haskell/wxcore/wxcore-0.92.3.0-r1.ebuild b/dev-haskell/wxcore/wxcore-0.92.3.0-r1.ebuild
deleted file mode 100644
index 6ec00209026f..000000000000
--- a/dev-haskell/wxcore/wxcore-0.92.3.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.5.3.9999
-
-WX_GTK_VER="3.0-gtk3"
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal wxwidgets
-
-DESCRIPTION="wxHaskell core"
-HOMEPAGE="https://wiki.haskell.org/WxHaskell"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="wxWinLL-3.1"
-SLOT="${WX_GTK_VER}/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="gstreamer"
-
-RDEPEND="dev-haskell/parsec:=[profile?]
- dev-haskell/stm:=[profile?]
- >=dev-haskell/wxc-0.92:${WX_GTK_VER}=[profile?,gstreamer?]
- >=dev-haskell/wxdirect-0.91:${WX_GTK_VER}=[profile?]
- >=dev-lang/ghc-7.4.1:=
- x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer?,opengl]
- !!dev-haskell/wxcore:3.0
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.23
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.92.2.0-ghc-8.4.patch
- "${FILESDIR}"/${PN}-0.92.3.0-cabal-3.patch
-)
-
-src_prepare() {
- default
-
- sed -e "s@wxdirect@wxdirect-${WX_GTK_VER}@g" \
- -i "${S}/Setup.hs" \
- || die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
-
- cabal_chdeps\
- 'containers >= 0.2 && < 0.6' 'containers >=0.2'
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=splitbase
-}