summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/x11/x11-1.8-r1.ebuild')
-rw-r--r--dev-haskell/x11/x11-1.8-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-haskell/x11/x11-1.8-r1.ebuild b/dev-haskell/x11/x11-1.8-r1.ebuild
deleted file mode 100644
index 9f9524f235d7..000000000000
--- a/dev-haskell/x11/x11-1.8-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.5.1.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-MY_PN="X11"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A binding to the X11 graphics library"
-HOMEPAGE="https://github.com/xmonad/X11"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="+screensaver +xinerama"
-
-RDEPEND="dev-haskell/data-default:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrandr
- screensaver? ( x11-libs/libXScrnSaver )
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6
-"
-
-PATCHES=("${FILESDIR}"/${P}-no-LDFLAGS.patch)
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- haskell-cabal_src_configure \
- --configure-option=$(use_with xinerama) \
- --configure-option=$(use_with screensaver xscreensaver)
-}