summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/x509-validation/x509-validation-1.6.12.ebuild')
-rw-r--r--dev-haskell/x509-validation/x509-validation-1.6.12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/x509-validation/x509-validation-1.6.12.ebuild b/dev-haskell/x509-validation/x509-validation-1.6.12.ebuild
new file mode 100644
index 000000000000..439d4d8797db
--- /dev/null
+++ b/dev-haskell/x509-validation/x509-validation-1.6.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="X.509 Certificate and CRL validation"
+HOMEPAGE="https://github.com/vincenthz/hs-certificate"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?] <dev-haskell/asn1-encoding-0.10:=[profile?]
+ >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ >=dev-haskell/cryptonite-0.24:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/hourglass:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?]
+ >=dev-haskell/x509-1.7.5:=[profile?]
+ >=dev-haskell/x509-store-1.6:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit )
+"