summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/x509-validation/x509-validation-1.6.5.ebuild')
-rw-r--r--dev-haskell/x509-validation/x509-validation-1.6.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/x509-validation/x509-validation-1.6.5.ebuild b/dev-haskell/x509-validation/x509-validation-1.6.5.ebuild
new file mode 100644
index 000000000000..017586fab345
--- /dev/null
+++ b/dev-haskell/x509-validation/x509-validation-1.6.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="X.509 Certificate and CRL validation"
+HOMEPAGE="https://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?] <dev-haskell/asn1-encoding-0.10:=[profile?]
+ >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ >=dev-haskell/cryptonite-0.8:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/hourglass:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-haskell/x509-1.6.2:=[profile?] <dev-haskell/x509-1.7:=[profile?]
+ >=dev-haskell/x509-store-1.6:=[profile?] <dev-haskell/x509-store-1.7:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"