summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/xml-conduit')
-rw-r--r--dev-haskell/xml-conduit/Manifest3
-rw-r--r--dev-haskell/xml-conduit/metadata.xml23
-rw-r--r--dev-haskell/xml-conduit/xml-conduit-1.1.0.9.ebuild42
-rw-r--r--dev-haskell/xml-conduit/xml-conduit-1.2.3.3.ebuild40
-rw-r--r--dev-haskell/xml-conduit/xml-conduit-1.3.1.ebuild39
5 files changed, 147 insertions, 0 deletions
diff --git a/dev-haskell/xml-conduit/Manifest b/dev-haskell/xml-conduit/Manifest
new file mode 100644
index 000000000000..003ef80a3fbc
--- /dev/null
+++ b/dev-haskell/xml-conduit/Manifest
@@ -0,0 +1,3 @@
+DIST xml-conduit-1.1.0.9.tar.gz 29805 SHA256 46f759c3657da413bc6941cd0c7d23744bbe1d8b669a7fa26f60db4997475d07 SHA512 94c3f925e3ace90c1434b0becdf1a6fa73db786d71522ea413bcf40fab653f415c4e7b8653ed423ca9f24665e4b8af92661aa436824c4a1dfb7d249702bf079e WHIRLPOOL f05299b94b588c010e9cae5a89097f52d7005f98e523e3d289f3a3fe8122886279570e3b0fdcf1a811b0a1953b83e6731a13543412c78efc32f1d65255e49700
+DIST xml-conduit-1.2.3.3.tar.gz 31240 SHA256 0bc599d6473f9c19c1f2c0f598799c586cf03c96fc21c8107d856ea20c15b378 SHA512 1a72b890ad3501d8a80a4030a01da35ef913f9245db9c870f13b5d266e073f14d490d38666c639575e5cf9a28c19e27378ffda9d4fe551b2b187f9e98167bd69 WHIRLPOOL 300217472c6acdbcb167d4d90337aae7bc915e3584542e8b277f72f4c811779e4bab273975f356c3affe65d2d076108be420dc21b276b6ee6f89d223e7ee8c35
+DIST xml-conduit-1.3.1.tar.gz 33304 SHA256 19e65bb1753f99c8a9f2011f2088639db3b8c06f72d29fea1464f623879b8f24 SHA512 939a891304647a8643bbf186269edb3a59930bf825dfa9e5f96382259ecc1c0787fbeb826ba0e5ec2105b263c8a639fc6079e8e3918b271f0e6ab9640133d1a5 WHIRLPOOL 176421a8ed579893f9bb8e5f649076fca1e06f42249db06626e73bc8213086442a6c977244f1dbbfc15c9d581ea5e90c4a45f54216cf5aa5608a3816af5a76a8
diff --git a/dev-haskell/xml-conduit/metadata.xml b/dev-haskell/xml-conduit/metadata.xml
new file mode 100644
index 000000000000..a8c6684bc6f2
--- /dev/null
+++ b/dev-haskell/xml-conduit/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package provides parsing and rendering functions for XML. It is based on the datatypes found in the xml-types package. This package is broken up into the following modules:
+
+ * Text.XML: DOM-based parsing and rendering. This is the most commonly used module.
+
+ * Text.XML.Cursor: A wrapper around "Text.XML" which allows bidirectional traversing of the DOM, similar to XPath. (Note: Text.XML.Cursor.Generic is the same concept, but will work with any node representation.)
+
+ * Text.XML.Unresolved: A slight modification to "Text.XML" which does not require all entities to be resolved at parsing. The datatypes are slightly more complicated here, and therefore this module is only recommended when you need to deal directly with raw entities.
+
+ * Text.XML.Stream.Parse: Streaming parser, including some streaming parser combinators.
+
+ * Text.XML.Stream.Render: Streaming renderer.
+
+ Additionally, the xml-hamlet package &lt;http://hackage.haskell.org/package/xml-hamlet&gt; provides a more convenient syntax for creating XML documents. For a more thorough tutorial on this library, please see &lt;http://www.yesodweb.com/book/xml-enumerator&gt;.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/xml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/xml-conduit/xml-conduit-1.1.0.9.ebuild b/dev-haskell/xml-conduit/xml-conduit-1.1.0.9.ebuild
new file mode 100644
index 000000000000..d53c227f6a8a
--- /dev/null
+++ b/dev-haskell/xml-conduit/xml-conduit-1.1.0.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure-Haskell utilities for dealing with XML with the conduit package"
+HOMEPAGE="http://github.com/snoyberg/xml"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/attoparsec-conduit-1.0:=[profile?]
+ >=dev-haskell/blaze-builder-0.2:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-conduit-1.0:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/failure-0.1:=[profile?] <dev-haskell/failure-0.3:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-0.4:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-0.5:=[profile?]
+ >=dev-haskell/system-filepath-0.4:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/xml-types-0.3.4:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit )
+"
diff --git a/dev-haskell/xml-conduit/xml-conduit-1.2.3.3.ebuild b/dev-haskell/xml-conduit/xml-conduit-1.2.3.3.ebuild
new file mode 100644
index 000000000000..ae1247a2517b
--- /dev/null
+++ b/dev-haskell/xml-conduit/xml-conduit-1.2.3.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure-Haskell utilities for dealing with XML with the conduit package"
+HOMEPAGE="http://github.com/snoyberg/xml"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-builder-0.2:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/system-filepath-0.4:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/xml-types-0.3.4:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit )
+"
diff --git a/dev-haskell/xml-conduit/xml-conduit-1.3.1.ebuild b/dev-haskell/xml-conduit/xml-conduit-1.3.1.ebuild
new file mode 100644
index 000000000000..dddad3e6cac7
--- /dev/null
+++ b/dev-haskell/xml-conduit/xml-conduit-1.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure-Haskell utilities for dealing with XML with the conduit package"
+HOMEPAGE="http://github.com/snoyberg/xml"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-builder-0.2:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/xml-types-0.3.4:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit )
+"