summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/yaml/yaml-0.8.20.ebuild')
-rw-r--r--dev-haskell/yaml/yaml-0.8.20.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-haskell/yaml/yaml-0.8.20.ebuild b/dev-haskell/yaml/yaml-0.8.20.ebuild
deleted file mode 100644
index 3bdfe6f0dfbc..000000000000
--- a/dev-haskell/yaml/yaml-0.8.20.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.5.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Support for parsing and rendering YAML documents"
-HOMEPAGE="https://github.com/snoyberg/yaml/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+no-examples no-exe no-unicode system-libyaml"
-
-RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
- >=dev-haskell/attoparsec-0.11.3.0:=[profile?]
- >=dev-haskell/conduit-1.1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
- dev-haskell/enclosed-exceptions:=[profile?]
- >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
- dev-haskell/scientific:=[profile?]
- dev-haskell/semigroups:=[profile?]
- dev-haskell/text:=[profile?]
- dev-haskell/unordered-containers:=[profile?]
- dev-haskell/vector:=[profile?]
- >=dev-lang/ghc-7.8.2:=
- !no-examples? ( dev-haskell/raw-strings-qq:=[profile?] )
- system-libyaml? ( dev-libs/libyaml )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( dev-haskell/aeson-qq
- dev-haskell/base-compat
- >=dev-haskell/hspec-1.3
- dev-haskell/hunit
- dev-haskell/mockery
- dev-haskell/temporary )
- system-libyaml? ( virtual/pkgconfig )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag no-examples no-examples) \
- $(cabal_flag no-exe no-exe) \
- $(cabal_flag no-unicode no-unicode) \
- $(cabal_flag system-libyaml system-libyaml)
-}