summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/yaml')
-rw-r--r--dev-haskell/yaml/Manifest1
-rw-r--r--dev-haskell/yaml/yaml-0.11.2.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/yaml/Manifest b/dev-haskell/yaml/Manifest
index 91472f562de0..ee853abc685c 100644
--- a/dev-haskell/yaml/Manifest
+++ b/dev-haskell/yaml/Manifest
@@ -1,3 +1,4 @@
+DIST yaml-0.11.2.0.tar.gz 29254 BLAKE2B ba9e0086fb4d93a9fd74ddf20dab71e3760af741476b13a1fe8d89944f5e5fc1aadce9a61a29a4a4607863378da98a5b5ead8bd7b4c7ffc3bae1e6b5695f977b SHA512 b90580ca37066401558c1a19148f70f6153a7f44f65ade99827adf20a4ba04edb8a9d6101b507014b92970d4bbe89c0fd89792a62206a2fbdc7ae5ff08915885
DIST yaml-0.8.10.1.tar.gz 73448 BLAKE2B 1b4e8b50d8e4913dd772253a8a7481802afe3dbc91538da9ce06437a09d155d2711540a87d4592a9953f6f316915da20caaf85a49f3f1369b2d98a5d8d9004ca SHA512 59b26eaca99379ff84cda6b8972ec2ff1e777536a754b9bda248d350a0797ef6c24d9cb86590062f4e6c12a5453224619a656c306a0292fdd1fe46e459a286e7
DIST yaml-0.8.15.2.tar.gz 75540 BLAKE2B fc7b03cdb582221c0d8611bee0f38189a4e55cc78a10c12906e09e1b4820de00298096d43289cd7d01ad23cd5fb9a221d9d976f90b0ec966f15975a97779312e SHA512 214a8203ca13350268b285d7049110ce91c03d6c8b0bc59187048b9efed15374c97a4b91e464e86f719d3190c0bc534f9ca4b7436fc33a4748d0fa84bb747bb4
DIST yaml-0.8.17.1.tar.gz 78775 BLAKE2B 66ddd1bf1ccb1f7b1314cd5b56987cc6e29da23ccadbde0d62baa6a9f143167e619f83bdb2734b8d561be030ebffed62ae610c417c52a40375b395ba38fd9ee7 SHA512 7119651e209942d41a9f5a542d365b5fea77c56d9dab012e3bf77234e6c6d23e2cff65c9b6c16ca185ff33338fd75c6b3f7dacaf1ff56f96c5773fcea70687f3
diff --git a/dev-haskell/yaml/yaml-0.11.2.0.ebuild b/dev-haskell/yaml/yaml-0.11.2.0.ebuild
new file mode 100644
index 000000000000..77c1d3c93b58
--- /dev/null
+++ b/dev-haskell/yaml/yaml-0.11.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for parsing and rendering YAML documents"
+HOMEPAGE="https://github.com/snoyberg/yaml#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+no-examples +no-exe"
+
+RDEPEND=">=dev-haskell/aeson-0.11:=[profile?]
+ >=dev-haskell/attoparsec-0.11.3.0:=[profile?]
+ >=dev-haskell/conduit-1.2.8:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/libyaml-0.1:=[profile?] <dev-haskell/libyaml-0.2:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.0.2:=
+ !no-examples? ( dev-haskell/raw-strings-qq:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+ test? ( dev-haskell/base-compat
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/mockery
+ dev-haskell/temporary
+ no-examples? ( dev-haskell/raw-strings-qq ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag no-examples no-examples) \
+ $(cabal_flag no-exe no-exe)
+}