summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/yesod-form')
-rw-r--r--dev-haskell/yesod-form/Manifest3
-rw-r--r--dev-haskell/yesod-form/metadata.xml18
-rw-r--r--dev-haskell/yesod-form/yesod-form-1.7.0.ebuild (renamed from dev-haskell/yesod-form/yesod-form-1.6.7.ebuild)13
-rw-r--r--dev-haskell/yesod-form/yesod-form-1.7.4.ebuild45
4 files changed, 64 insertions, 15 deletions
diff --git a/dev-haskell/yesod-form/Manifest b/dev-haskell/yesod-form/Manifest
index 7d436b76b924..813539bb2d01 100644
--- a/dev-haskell/yesod-form/Manifest
+++ b/dev-haskell/yesod-form/Manifest
@@ -1 +1,2 @@
-DIST yesod-form-1.6.7.tar.gz 33673 BLAKE2B 0675fc4bdb5e5ae9b7a7556378c14d4c8a8ff85ae055f3f8989667a6de209e8f1a318bd69148e81ba6cf121c5f0ac18fb20bcccfa6bd85d31ce164a30ba6282d SHA512 a23c2cb67ed0a87afde9e9e903aa789f8fd9c071893a1bebd0ff9dc3dec6e8e03dd08a4a7ef6ef2d438fbf62597ea0181a038bd7bb5631199c9be83d2a8aef0c
+DIST yesod-form-1.7.0.tar.gz 34435 BLAKE2B 86b299931316eaece475ee741357acf8e61797bd00cdbdaf9298a1ac6967b735915f0169eb12559ef7296466f61fd20a6624c62c08a5ef148566925659da1e05 SHA512 dc5373c62e78d79e570171c608fa2e9cfb2092a859b81a881ab69a406c357cc9eeff0ff04d0c08f8cc29cf66ef488ce6b96195d26b9c6dff879a1fea96eff013
+DIST yesod-form-1.7.4.tar.gz 35498 BLAKE2B 71812b32c44b21cd36045b821a6602551b09ec57be4c9e378c303b5e68fe7165950b623c013ee6ea3d35c0c33b8fd285fb138d480678245be1404921c753cb09 SHA512 8233cc85d7fd6f6e2d815fd38d3d0d2ebd1c7c11249ee3708dace0934e961319cf4d7063e8982b9f7bd329c3d110bade8013dfe987d6cbdecfc6c15e87abb982
diff --git a/dev-haskell/yesod-form/metadata.xml b/dev-haskell/yesod-form/metadata.xml
index 062519021e82..a8a9666053c5 100644
--- a/dev-haskell/yesod-form/metadata.xml
+++ b/dev-haskell/yesod-form/metadata.xml
@@ -1,11 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
-<use>
- <flag name="network-uri">Get Network.URI from the network-uri package</flag>
-</use>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="network-uri">Get Network.URI from the network-uri package</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">yesod-form</remote-id>
+ <remote-id type="github">yesodweb/yesod</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/yesod-form/yesod-form-1.6.7.ebuild b/dev-haskell/yesod-form/yesod-form-1.7.0.ebuild
index 112ad117bb73..8b19fef258e0 100644
--- a/dev-haskell/yesod-form/yesod-form-1.6.7.ebuild
+++ b/dev-haskell/yesod-form/yesod-form-1.7.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.2
+# ebuild generated by hackport 0.6.7.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -14,7 +14,7 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+network-uri"
RDEPEND="dev-haskell/aeson:=[profile?]
@@ -27,18 +27,17 @@ RDEPEND="dev-haskell/aeson:=[profile?]
>=dev-haskell/email-validate-1.0:=[profile?]
dev-haskell/persistent:=[profile?]
dev-haskell/resourcet:=[profile?]
- dev-haskell/semigroups:=[profile?]
>=dev-haskell/shakespeare-2.0:=[profile?]
>=dev-haskell/text-0.9:=[profile?]
>=dev-haskell/wai-1.3:=[profile?]
>=dev-haskell/xss-sanitize-0.3.0.1:=[profile?]
>=dev-haskell/yesod-core-1.6:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
>=dev-haskell/yesod-persistent-1.6:=[profile?] <dev-haskell/yesod-persistent-1.7:=[profile?]
- >=dev-lang/ghc-7.8.2:=
+ >=dev-lang/ghc-8.4.3:=
network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
+ >=dev-haskell/cabal-2.2.0.1
test? ( dev-haskell/hspec )
"
diff --git a/dev-haskell/yesod-form/yesod-form-1.7.4.ebuild b/dev-haskell/yesod-form/yesod-form-1.7.4.ebuild
new file mode 100644
index 000000000000..f40f5131eed9
--- /dev/null
+++ b/dev-haskell/yesod-form/yesod-form-1.7.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Form handling support for Yesod Web Framework"
+HOMEPAGE="https://www.yesodweb.com/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+network-uri"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/email-validate-1.0:=[profile?]
+ dev-haskell/persistent:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ >=dev-haskell/shakespeare-2.0:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/xss-sanitize-0.3.0.1:=[profile?]
+ >=dev-haskell/yesod-core-1.6:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
+ >=dev-haskell/yesod-persistent-1.6:=[profile?] <dev-haskell/yesod-persistent-1.7:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/hspec )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}