summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/yesod/yesod-1.6.2.1.ebuild')
-rw-r--r--dev-haskell/yesod/yesod-1.6.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/yesod/yesod-1.6.2.1.ebuild b/dev-haskell/yesod/yesod-1.6.2.1.ebuild
new file mode 100644
index 000000000000..e0052e1cac93
--- /dev/null
+++ b/dev-haskell/yesod/yesod-1.6.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Creation of type-safe, RESTful web applications"
+HOMEPAGE="https://www.yesodweb.com/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/fast-logger:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ dev-haskell/monad-logger:=[profile?]
+ dev-haskell/shakespeare:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/wai-extra-1.3:=[profile?]
+ dev-haskell/wai-logger:=[profile?]
+ >=dev-haskell/warp-1.3:=[profile?]
+ >=dev-haskell/yaml-0.8.17:=[profile?]
+ >=dev-haskell/yesod-core-1.6:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
+ >=dev-haskell/yesod-form-1.6:=[profile?] <dev-haskell/yesod-form-1.8:=[profile?]
+ >=dev-haskell/yesod-persistent-1.6:=[profile?] <dev-haskell/yesod-persistent-1.7:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"