summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild')
-rw-r--r--dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild b/dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild
new file mode 100644
index 000000000000..c512e302adab
--- /dev/null
+++ b/dev-haskell/zip-archive/zip-archive-0.2.3.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Library for creating and modifying zip archives"
+HOMEPAGE="http://github.com/jgm/zip-archive"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/binary-0.5:=[profile?]
+ >=dev-haskell/digest-0.0.0.1:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( app-arch/zip
+ dev-haskell/hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}