summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hashtables/Manifest1
-rw-r--r--dev-haskell/hashtables/hashtables-1.3.1.ebuild47
-rw-r--r--dev-haskell/hashtables/metadata.xml16
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-haskell/hashtables/Manifest b/dev-haskell/hashtables/Manifest
new file mode 100644
index 000000000000..0a4264f7732a
--- /dev/null
+++ b/dev-haskell/hashtables/Manifest
@@ -0,0 +1 @@
+DIST hashtables-1.3.1.tar.gz 58697 BLAKE2B d543987f667553b0739b414600190127840cb656d1509cb2541274bed00c298d176ff8ae059f79cc1dbf9201f1e76697103c9620a6208e9a9bf744cafea379d5 SHA512 b6430e092cfa9cde3dbea34cd9e2a10869c41e40e88f79e28aa6aabfdcd359dd74fb87020f8b9e004b817a6e9a8825335fcc91c2b88f7eb93b25758c71c77833
diff --git a/dev-haskell/hashtables/hashtables-1.3.1.ebuild b/dev-haskell/hashtables/hashtables-1.3.1.ebuild
new file mode 100644
index 000000000000..13d8df830c14
--- /dev/null
+++ b/dev-haskell/hashtables/hashtables-1.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: sse42:cpu_flags_x86_sse4_2,+unsafe-tricks,-portable
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Mutable hash tables in the ST monad"
+HOMEPAGE="https://github.com/gregorycollins/hashtables"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="bounds-checking cpu_flags_x86_sse4_2 debug detailed-profiling"
+
+RDEPEND="
+ =dev-haskell/hashable-1.4*:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.14
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
+ >=dev-haskell/mwc-random-0.8 <dev-haskell/mwc-random-0.16
+ >=dev-haskell/quickcheck-2.3.0.2
+ >=dev-haskell/test-framework-0.3.1 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.6 <dev-haskell/test-framework-hunit-3
+ >=dev-haskell/test-framework-quickcheck2-0.2.6 <dev-haskell/test-framework-quickcheck2-0.4
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bounds-checking bounds-checking) \
+ $(cabal_flag debug debug) \
+ $(cabal_flag detailed-profiling detailed-profiling) \
+ --flag=-portable \
+ $(cabal_flag cpu_flags_x86_sse4_2 sse42) \
+ --flag=unsafe-tricks
+}
diff --git a/dev-haskell/hashtables/metadata.xml b/dev-haskell/hashtables/metadata.xml
new file mode 100644
index 000000000000..0cf72ece23fa
--- /dev/null
+++ b/dev-haskell/hashtables/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="bounds-checking">if on, use bounds-checking array accesses</flag>
+ <flag name="detailed-profiling">add detailed profiling information to profiled build-depends</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">hashtables</remote-id>
+ <remote-id type="github">gregorycollins/hashtables</remote-id>
+ </upstream>
+</pkgmetadata>