summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-collections/commons-collections-3.2.1-r3.ebuild')
-rw-r--r--dev-java/commons-collections/commons-collections-3.2.1-r3.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-java/commons-collections/commons-collections-3.2.1-r3.ebuild b/dev-java/commons-collections/commons-collections-3.2.1-r3.ebuild
index cfd46905336a..75a4556fc9c6 100644
--- a/dev-java/commons-collections/commons-collections-3.2.1-r3.ebuild
+++ b/dev-java/commons-collections/commons-collections-3.2.1-r3.ebuild
@@ -19,17 +19,20 @@ IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="
- >=virtual/jdk-1.8
+ >=virtual/jdk-1.8:*
test? (
dev-java/junit:0
dev-java/ant-junit:0
)"
-RDEPEND=">=virtual/jre-1.8"
+RDEPEND=">=virtual/jre-1.8:*"
S="${WORKDIR}/${P}-src"
-PATCHES=( "${FILESDIR}/${P}-Java-8.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-Java-8.patch"
+ "${FILESDIR}/${P}-fix-tests.patch"
+)
src_prepare() {
default
@@ -38,7 +41,7 @@ src_prepare() {
src_compile() {
local antflags
if use test; then
- antflags="tf.jar -Djunit.jar=$(java-pkg_getjars junit)"
+ antflags="tf.jar -Djunit.jar=$(java-pkg_getjars --build-only junit)"
fi
eant jar $(use_doc) ${antflags}
}