summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild')
-rw-r--r--dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild b/dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild
new file mode 100644
index 000000000000..22b9af5b27f8
--- /dev/null
+++ b/dev-java/findbugs-annotations/findbugs-annotations-3.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom findbugs-annotations-3.0.1.pom --download-uri https://repo1.maven.org/maven2/com/google/code/findbugs/findbugs-annotations/3.0.1/findbugs-annotations-3.0.1-sources.jar --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild findbugs-annotations-3.0.1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="com.google.code.findbugs:findbugs-annotations:3.0.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Annotation defined by the FindBugs tool"
+HOMEPAGE="http://findbugs.sourceforge.net/"
+SRC_URI="https://repo1.maven.org/maven2/com/google/code/findbugs/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: ${P}.pom
+# com.google.code.findbugs:jsr305:3.0.1 -> >=dev-java/jsr305-3.0.2:0
+
+CP_DEPEND="
+ >=dev-java/jsr305-3.0.2:0
+"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CP_DEPEND}
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CP_DEPEND}"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"