summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jopt-simple/jopt-simple-4.6-r1.ebuild')
-rw-r--r--dev-java/jopt-simple/jopt-simple-4.6-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/jopt-simple/jopt-simple-4.6-r1.ebuild b/dev-java/jopt-simple/jopt-simple-4.6-r1.ebuild
new file mode 100644
index 000000000000..d53d799d1b99
--- /dev/null
+++ b/dev-java/jopt-simple/jopt-simple-4.6-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java library for parsing command line options"
+HOMEPAGE="https://pholser.github.com/jopt-simple/"
+SRC_URI="https://github.com/pholser/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4.6"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"
+
+JAVA_SRC_DIR="src/main/java"
+
+S="${WORKDIR}/${PN}-${PN}-8808a39"