summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/json/json-20150729.ebuild')
-rw-r--r--dev-java/json/json-20150729.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-java/json/json-20150729.ebuild b/dev-java/json/json-20150729.ebuild
new file mode 100644
index 000000000000..6e33966cff63
--- /dev/null
+++ b/dev-java/json/json-20150729.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java implementation of the JavaScript Object Notation"
+HOMEPAGE="http://www.json.org/java/"
+SRC_URI="https://github.com/douglascrockford/JSON-java/archive/${PV}.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/JSON-java-${PV}"
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ chmod a-x *.java || die
+ mkdir -p src || die
+ mv *.java src || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc README || die
+}