summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/libg')
-rw-r--r--dev-java/libg/Manifest1
-rw-r--r--dev-java/libg/libg-2.1.0-r1.ebuild48
-rw-r--r--dev-java/libg/metadata.xml8
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-java/libg/Manifest b/dev-java/libg/Manifest
new file mode 100644
index 000000000000..cad265698532
--- /dev/null
+++ b/dev-java/libg/Manifest
@@ -0,0 +1 @@
+DIST bndlib-2.1.0.tar.gz 123217291 SHA256 5e4c3c5d786acc1044103f57f4769acf54ea7d247f58f3c6a7b7769fb37df30f SHA512 6965143ced45c15fc2316716de32e80506cc411d52309b24313fff37e0713a45ad200d5b3701f0d47a131a3163ec266ed8acb4544884cd1c59c9716c7a2b285e WHIRLPOOL 3df261dec93655d2f4e483952b58d531fdf1936c505552f013f9447ac7fc8100e51f2412fd66224fe7871fa68fe1a6ec86c9c2787ffbfc65c8dc9863bac31fe5
diff --git a/dev-java/libg/libg-2.1.0-r1.ebuild b/dev-java/libg/libg-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..38f2b0a1a317
--- /dev/null
+++ b/dev-java/libg/libg-2.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Lots of small utilities for bndlib, a swiss army knife for OSGi"
+HOMEPAGE="http://www.aqute.biz/Bnd/Bnd"
+SRC_URI="https://github.com/bndtools/bnd/archive/${PV}.REL.tar.gz -> bndlib-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+# Tests depend on biz.aQute.junit, which depends on biz.aQute.bndlib, which on
+# its own turn again depends on aQute.libg again; we can temporarily assume that
+# if bndlib tests pass that libg is sufficiently tested, in the future we should
+# look whether it is feasible to combine the packages or otherwise temporarily
+# build biz.aquite.bndlib and biz.aqute.junit in this package.
+RESTRICT="test"
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/bnd-${PV}.REL/aQute.${PN}"
+
+EANT_BUILD_TARGET="build"
+
+java_prepare() {
+ # Move the correct build.xml into place, needed for testing.
+ cp ../cnf/build.xml . || die "Failed to move build file into the right place."
+
+ # Remove bundled jar files.
+ find . -name '*.jar' -delete
+
+ # Remove test files
+ if ! use test ; then
+ find src/test -name '*.java' -delete || die "Failed to remove test files."
+ fi
+}
+
+src_install() {
+ java-pkg_newjar generated/aQute.${PN}.jar
+}
diff --git a/dev-java/libg/metadata.xml b/dev-java/libg/metadata.xml
new file mode 100644
index 000000000000..f74b561cfceb
--- /dev/null
+++ b/dev-java/libg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">bndtools/bnd</remote-id>
+ </upstream>
+</pkgmetadata>