summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/typesafe-config/typesafe-config-1.2.1.ebuild')
-rw-r--r--dev-java/typesafe-config/typesafe-config-1.2.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/typesafe-config/typesafe-config-1.2.1.ebuild b/dev-java/typesafe-config/typesafe-config-1.2.1.ebuild
new file mode 100644
index 000000000000..dadedeef3ad5
--- /dev/null
+++ b/dev-java/typesafe-config/typesafe-config-1.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A library of arguably useful Java utilities"
+HOMEPAGE="https://github.com/typesafehub/config"
+SRC_URI="https://github.com/typesafehub/config/archive/v${PV}.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.6"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/zip"