summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/typesafe-config/typesafe-config-1.3.0.ebuild')
-rw-r--r--dev-java/typesafe-config/typesafe-config-1.3.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/typesafe-config/typesafe-config-1.3.0.ebuild b/dev-java/typesafe-config/typesafe-config-1.3.0.ebuild
new file mode 100644
index 000000000000..34440cdbdaad
--- /dev/null
+++ b/dev-java/typesafe-config/typesafe-config-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 java-pkg-simple
+
+JAVA_PKG_IUSE="doc source"
+
+DESCRIPTION="a library of arguably useful Java utilities"
+HOMEPAGE="https://github.com/typesafehub/config"
+SRC_URI="https://github.com/typesafehub/config/archive/v${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
+IUSE="doc source"
+
+CDEPEND=""
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/zip
+ ${CDEPEND}"