summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/json-simple/Manifest1
-rw-r--r--dev-java/json-simple/json-simple-2.3.1.ebuild26
-rw-r--r--dev-java/json-simple/metadata.xml2
3 files changed, 28 insertions, 1 deletions
diff --git a/dev-java/json-simple/Manifest b/dev-java/json-simple/Manifest
index 2d05f995e396..230b70a31c26 100644
--- a/dev-java/json-simple/Manifest
+++ b/dev-java/json-simple/Manifest
@@ -1 +1,2 @@
DIST json-simple-1.1.tar.gz 22154 BLAKE2B 594717df45d56b4e70cee9aadca661a9da7e19c2a77e5ab2176396c48bdf061f25db0e4cbf5b93b12dc862dfca593a71dcd154f24c914a4d2ff510e3f4b11570 SHA512 f09cb298254a8f35b534670d6a1801eeaf58385529f459f413aed556df1ac577bea6e678a32065077abc851dc310b3af38b818f1737bd255f05e756d7e2da066
+DIST json-simple-2.3.1.tar.gz 56230 BLAKE2B c4a196ffa67a729a1964db8c30b95ccb0bef0c213a76e37e463153a895a5fdb8c6f02f6d188d28f0b56665bf24c75dbdeeb42d88297c8df5e1b409606b0f04f2 SHA512 b80ea33480f8b32511ee2db5cfacc9c02cb5dbf0765b41fb76e099f41ac6c0ea69d75fdf0a5f783e3bfb7b4f200c49ca192a3321e0d8480b3a8b67ada469dbb1
diff --git a/dev-java/json-simple/json-simple-2.3.1.ebuild b/dev-java/json-simple/json-simple-2.3.1.ebuild
new file mode 100644
index 000000000000..e7d6ef026a03
--- /dev/null
+++ b/dev-java/json-simple/json-simple-2.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="source doc test"
+MAVEN_ID="com.github.cliftonlabs:json-simple:2.3.1"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java 7+ toolkit to quickly develop RFC 4627 JSON compatible applications"
+HOMEPAGE="https://www.json.org"
+SRC_URI="https://github.com/cliftonlabs/json-simple/archive/json-simple-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
diff --git a/dev-java/json-simple/metadata.xml b/dev-java/json-simple/metadata.xml
index 0c65410880a7..22e6f7bfad33 100644
--- a/dev-java/json-simple/metadata.xml
+++ b/dev-java/json-simple/metadata.xml
@@ -13,6 +13,6 @@
website,I found that wrappers to JSONObject and JSONArray can be simpler,
due to the simplicity of JSON itself. So I wrote the JSON.simple package.</longdescription>
<upstream>
- <remote-id type="google-code">json-simple</remote-id>
+ <remote-id type="github">cliftonlabs/json-simple</remote-id>
</upstream>
</pkgmetadata>