summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jgoodies-looks/Manifest2
-rw-r--r--dev-java/jgoodies-looks/files/jgoodies-looks-1.2.2-build.xml83
-rw-r--r--dev-java/jgoodies-looks/files/jgoodies-looks-1.2.2-plastic.txt8
-rw-r--r--dev-java/jgoodies-looks/files/jgoodies-looks-2.3.1-build.xml.patch61
-rw-r--r--dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r2.ebuild49
-rw-r--r--dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild61
6 files changed, 264 insertions, 0 deletions
diff --git a/dev-java/jgoodies-looks/Manifest b/dev-java/jgoodies-looks/Manifest
index e5d55453b2e4..7aa430b6b3be 100644
--- a/dev-java/jgoodies-looks/Manifest
+++ b/dev-java/jgoodies-looks/Manifest
@@ -1 +1,3 @@
DIST jgoodies-looks-2_6_0.zip 2444893 SHA256 2f992c25309e00aadba7c6a3af5c6596b3d487bff64fb1a5e94921647929f7e5 SHA512 1c33413379f391109d1db35bdf301acf0cc6d66bf8aa1026280015946bddb230b4cc1d233b700d46a519fb02c169df4670c874058f5e636e1e924a9d3a42442a WHIRLPOOL f6848e9011001353cb115298465e7da981335d15f3839ca749418d975965358bc9595dbf9a1a36be9b240d0b92866a953dc4a7500b2eb8ecfe50ce46b5e40973
+DIST looks-1_2_2.zip 1811849 SHA256 d7b6cc296cf9284bcbeda9a2c9497e804abae66ae3fc3f31174cf19e9a0bebae SHA512 d9c5f0590a44dbc7d778a9da135361f5753eca4d47bef3636f21aa0d014df86dbad90031b5289928b99c352147ea702948028b18b36eb3bc44aef800326fb302 WHIRLPOOL 20b67ffb888322967103de3953ce825976582f5031ee1609acc91c86d9a621d22656b3337734ecee447c665b35784c595165f7732f2eb0fccc988fa4ac734235
+DIST looks-2_3_1.zip 2105839 SHA256 f66b7e79ca53e849d6082ba0d937f9056d855cd6269edb9b3c52dd1347b14b8d SHA512 61278cc0b8556ce19cfb5bdaaab2b42d7035fcdf71d614a8d3673629d5b04c5698e2be521df3e0518e781f78c03a8d3f466f1fdfba525f679e9de7409faf1088 WHIRLPOOL 964806f73587ed116e4cfb6c330f0231598fc651286085c40bd4a6acedc9a1565bdbe5a4ff48f3e7dfb976a4a28ca667994d146b3d3bc9bfbeacf3c520915425
diff --git a/dev-java/jgoodies-looks/files/jgoodies-looks-1.2.2-build.xml b/dev-java/jgoodies-looks/files/jgoodies-looks-1.2.2-build.xml
new file mode 100644
index 000000000000..b24ec32156b4
--- /dev/null
+++ b/dev-java/jgoodies-looks/files/jgoodies-looks-1.2.2-build.xml
@@ -0,0 +1,83 @@
+<?xml version="1.0"?>
+
+<project name="Plastic" default="jar" basedir=".">
+
+ <!-- This is a customized build.xml for portage! -->
+ <!--
+ <property file="${basedir}/build.properties"/>
+ <property file="${basedir}/default.properties"/>
+ -->
+
+ <property name="build" value="${basedir}/build"/>
+
+ <property name="spec.title" value="JGoodies Looks"/>
+ <property name="spec.version" value="1.2"/>
+ <property name="spec.vendor" value="Apache Software Foundation"/>
+ <property name="imp.title" value="com.jgoodies.plaf"/>
+ <property name="imp.version" value="1.2.2"/>
+ <property name="imp.vendor" value="Apache Software Foundation"/>
+
+ <property name="plaf.src" value="${basedir}/com/jgoodies/plaf"/>
+ <property name="clearlook.src" value="${basedir}/com/jgoodies/clearlook"/>
+
+ <property name="clearlook.javadoc" value="${build}/doc/clearlook"/>
+ <property name="clearlook.packages" value="com.jgoodies.clearlook.*"/>
+
+ <property name="plastic.javadoc" value="${build}/doc/plastic"/>
+ <property name="plastic.packages" value="com.jgoodies.clearlook.*"/>
+
+ <target name="init">
+ <tstamp />
+ <mkdir dir="${build}"/>
+ <mkdir dir="${build}/doc"/>
+ </target>
+
+ <target name="manifest" depends="init">
+ <manifest file="MANIFEST.MF" mode="update">
+ <attribute name="Built-By" value="Gentoo Portage"/>
+
+ <section name="com/jgoodies/plaf">
+ <attribute name="Specification-Title" value="${spec.title}"/>
+ <attribute name="Specification-Version" value="${spec.version}"/>
+ <attribute name="Specification-Vendor" value="${spec.vendor}"/>
+ <attribute name="Implementation-Title" value="${imp.title}"/>
+ <attribute name="Implementation-Version" value="${imp.version}"/>
+ <attribute name="Implementation-Vendor" value="${imp.vendor}"/>
+ </section>
+ </manifest>
+ </target>
+
+ <target name="compile" depends="init">
+ <javac srcdir="${plaf.src};${clearlook.src}"
+ destdir="${build}"
+ source="1.4"
+ target="1.4"/>
+
+ <!--
+ Copy application resources
+ NOTE: THIS MAY NEED TO BE CHANGED IN FUTURE VERSIONS!!
+ -->
+ <copy toDir="${build}/com/jgoodies/plaf">
+ <fileset dir="${plaf.src}" excludes="**/*.java"/>
+ </copy>
+ </target>
+
+ <target name="javadoc" depends="compile">
+ <javadoc sourcepath="${basedir}"
+ destdir="${clearlook.javadoc}"
+ packagenames="${clearlook.packages}"/>
+ <javadoc sourcepath="${basedir}"
+ destdir="${plastic.javadoc}"
+ packagenames="${plastic.packages}"/>
+ </target>
+
+ <target name="jar" depends="compile,manifest">
+ <jar jarfile="looks.jar" manifest="MANIFEST.MF">
+ <fileset dir="${build}"/>
+ <zipfileset dir="${basedir}"
+ includes="plastic.txt"
+ fullpath="META-INF/services/javax.swing.LookAndFeel"/>
+ </jar>
+ </target>
+
+</project>
diff --git a/dev-java/jgoodies-looks/files/jgoodies-looks-1.2.2-plastic.txt b/dev-java/jgoodies-looks/files/jgoodies-looks-1.2.2-plastic.txt
new file mode 100644
index 000000000000..ab3737ca6a30
--- /dev/null
+++ b/dev-java/jgoodies-looks/files/jgoodies-looks-1.2.2-plastic.txt
@@ -0,0 +1,8 @@
+# JGoodies Plastic L&F- replacement for Metal
+com.jgoodies.plaf.plastic.PlasticLookAndFeel
+# JGoodies Plastic 3D L&F
+com.jgoodies.plaf.plastic.Plastic3DLookAndFeel
+# JGoodies Plastic XP L&F
+com.jgoodies.plaf.plastic.PlasticXPLookAndFeel
+# JGoodies Windows L&F
+com.jgoodies.plaf.windows.ExtWindowsLookAndFeel
diff --git a/dev-java/jgoodies-looks/files/jgoodies-looks-2.3.1-build.xml.patch b/dev-java/jgoodies-looks/files/jgoodies-looks-2.3.1-build.xml.patch
new file mode 100644
index 000000000000..e6c0a4be2330
--- /dev/null
+++ b/dev-java/jgoodies-looks/files/jgoodies-looks-2.3.1-build.xml.patch
@@ -0,0 +1,61 @@
+--- build.xml.orig 2006-10-12 23:54:26.000000000 +0200
++++ build.xml 2006-10-12 23:57:36.000000000 +0200
+@@ -100,7 +100,6 @@
+ srcdir ="${src.core.dir}"
+ destdir ="${build.core.dir}"
+ encoding ="${build.encoding}"
+- executable ="${build.compile.executable}"
+ fork ="${build.compile.fork}"
+ debug ="${build.compile.debug}"
+ depend ="${build.compile.depend}"
+@@ -109,8 +108,7 @@
+ optimize ="${build.compile.optimize}"
+ source ="${build.compile.source}"
+ target ="${build.compile.target}"
+- verbose ="${build.compile.verbose}"
+- bootclasspath="${build.boot.classpath}" />
++ verbose ="${build.compile.verbose}"/>
+
+ <copy toDir="${build.core.dir}" >
+ <fileset dir="${src.core.dir}"
+@@ -127,7 +125,6 @@
+ srcdir ="${src.demo.dir}"
+ destdir ="${build.demo.dir}"
+ encoding ="${build.encoding}"
+- executable ="${build.compile.executable}"
+ fork ="${build.compile.fork}"
+ debug ="${build.compile.debug}"
+ depend ="${build.compile.depend}"
+@@ -137,7 +134,6 @@
+ source ="${build.compile.source}"
+ target ="${build.compile.target}"
+ verbose ="${build.compile.verbose}"
+- bootclasspath="${build.boot.classpath}"
+ classpathref ="classpath.demo" />
+ </target>
+
+@@ -149,7 +145,6 @@
+ srcdir ="${src.test.dir}"
+ destdir ="${build.test.dir}"
+ encoding ="${build.encoding}"
+- executable ="${build.compile.executable}"
+ fork ="${build.compile.fork}"
+ debug ="${build.compile.debug}"
+ depend ="${build.compile.depend}"
+@@ -159,7 +154,6 @@
+ source ="${build.compile.source}"
+ target ="${build.compile.target}"
+ verbose ="${build.compile.verbose}"
+- bootclasspath="${build.boot.classpath}"
+ classpathref ="classpath.tests" />
+ </target>
+
+@@ -235,7 +229,7 @@
+ </target>
+
+ <!-- ***************************************************************** -->
+- <target name="jar-all" depends="compile, manifest"
++ <target name="jar-all" depends="compile-core, manifest"
+ description="Creates the library jar with all JGoodies l&amp;fs." >
+
+ <jar
diff --git a/dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r2.ebuild b/dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..5fa20a3ba568
--- /dev/null
+++ b/dev-java/jgoodies-looks/jgoodies-looks-1.2.2-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="looks"
+MY_PV="${PV//./_}"
+
+DESCRIPTION="JGoodies Looks Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}-${MY_PV}.zip"
+
+LICENSE="BSD"
+SLOT="1.2"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+EANT_DOC_TARGET="javadoc"
+
+java_prepare() {
+ java-pkg_clean
+
+ cp "${FILESDIR}/${P}-build.xml" "${S}"/build.xml || die
+ cp "${FILESDIR}/${P}-plastic.txt" "${S}"/plastic.txt || die
+
+ unzip ${MY_PN}-${PV}-src.zip || die
+}
+
+src_install() {
+ java-pkg_dojar "${MY_PN}.jar"
+
+ dodoc RELEASE-NOTES.txt
+ use source && java-pkg_dosrc com
+ use doc && java-pkg_dohtml -r build/doc
+ use examples && java-pkg_doexamples src/examples
+}
diff --git a/dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild b/dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..58d544b4d1df
--- /dev/null
+++ b/dev-java/jgoodies-looks/jgoodies-looks-2.3.1-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="looks"
+MY_PV="${PV//./_}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="JGoodies Looks Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="2.0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="
+ >=virtual/jdk-1.4
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# bug #150970
+EANT_FILTER_COMPILER="jikes"
+# jar target fails unless we make descriptors.dir an existing directory
+# update: it's where it looks for all.txt file
+EANT_EXTRA_ARGS="-Ddescriptors.dir=\"${S}\""
+
+EANT_BUILD_TARGET="jar-all"
+
+java_prepare() {
+ # remove the bootclasspath brokedness, make building demo optional
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+
+ # unzip the look&feel settings from bundled jar before we delete it
+ unzip -j looks-${PV}.jar META-INF/services/javax.swing.LookAndFeel \
+ || die "unzip of javax.swing.LookAndFeel failed"
+ # and rename it to what build.xml expects
+ mv javax.swing.LookAndFeel all.txt || die
+
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg_dojar build/looks.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ dohtml README.html || die
+ use doc && java-pkg_dojavadoc build/docs/api
+ use source && java-pkg_dosrc src/core/com
+ use examples && java-pkg_doexamples src/demo
+}