summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/json-smart/Manifest1
-rw-r--r--dev-java/json-smart/json-smart-1.3.3.ebuild26
-rw-r--r--dev-java/json-smart/metadata.xml11
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-java/json-smart/Manifest b/dev-java/json-smart/Manifest
new file mode 100644
index 000000000000..e20ab08d97bb
--- /dev/null
+++ b/dev-java/json-smart/Manifest
@@ -0,0 +1 @@
+DIST json-smart-1.3.3.tar.gz 49430 BLAKE2B 805e16e0de5321a2e8164468757e9b722849f0fe90fd6822cc99f7afffd9f4e480fc4e14c2bbd12b325a27abc8ca7e93b4a17ce56ac352117cef336e1ebb3fe9 SHA512 c6006c6a00a085ea8810e18889450d11240dc3671351f20602214db418107808df1f413fe67c199d6529e4c0087f2533601826666ac4fa493bcaf72d2c18ed83
diff --git a/dev-java/json-smart/json-smart-1.3.3.ebuild b/dev-java/json-smart/json-smart-1.3.3.ebuild
new file mode 100644
index 000000000000..2249a996229c
--- /dev/null
+++ b/dev-java/json-smart/json-smart-1.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="net.minidev:json-smart:1.3.3"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="old JSON parser"
+HOMEPAGE="https://urielch.github.io"
+SRC_URI="https://github.com/netplex/json-smart-v1/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/${PN}-v1-${PV}/json-smart"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
diff --git a/dev-java/json-smart/metadata.xml b/dev-java/json-smart/metadata.xml
new file mode 100644
index 000000000000..a6544c9f9455
--- /dev/null
+++ b/dev-java/json-smart/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">netplex/json-smart-v1</remote-id>
+ </upstream>
+</pkgmetadata>